-bash: sudo: command not found - even sudo etc not found

Hi everybody, I am really new here and I hope somebody can enlighten me.

Finally I want to control 433MHz sockets via HA. So I´ve installed HA on an RPi4. I use ssh to get onto my RP. So the next step was to install the following: pp3 install rpi-rf. And here I faced the first time the prob, that almost nothing can be found. I´ve tried to figure out what python version is installed. The answer where the same:
~ $ python3 --version
-bash: python3: command not found

Can please somebody tell me what to install or how two update the system?


You posted this in Home Assistant OS so is that what you have installed on your RPi4? If so then the answer is you don’t install software. HA OS is a self-contained operating system designed for one purpose - to manage and run Home Assistant. You can install add-ons but its not a normal linux system, you can’t just install or change random packages otherwise you may break dependencies.

Also how did you SSH in? Using the SSH add-on? If so you aren’t actually SSH’ed into the operating system which is why you are seeing such a minimal set of options, you’re in a docker container. Each component of HA and each add-on is a separate docker container.

1 Like

Well, yes I installed an HA OS. But I just supposed that can act on the terminal in a common way. But what you write sounds logic. So maybe the better way would be the installation of an common raspi OS and afterwards install the HA as a separate programm?

And yes, I use SSH via add-on…

Well you can do that but just an FYI Raspberry Pi OS isn’t on the supported list of operating systems for a supervised install.

Your options for running on a raspberry pi are here and your options for running on any random linux box are here. Essentially you’re looking at the following:

  1. Run HA OS and stick to add-ons and HA components.
  2. Install debian buster and do a supervised install.
  3. Set up HAOS as a virtual machine
  4. Install HA only (no supervisor and no add-ons) using either the container or core install process

BTW I don’t really know what that thing is you’re trying to use but have you made sure its not in the list of integrations already? There’s also HACS if you haven’t seen that which has a very extensive list of custom components the community has made. Also if you search the forum you can find lots more community made stuff such as custom components and add-ons that require adding their repo to the list of repositories in either HACS or the add-ons list.

This is a very strong community so personally I’ve found its pretty rare that you’re the only one trying to do something. Often someone else has already encountered it, solved it and shared the solution.

1 Like

I’m just now realizing pp3 install rpi-rf is a typo for pip3 install rpi-rf. I feel silly lol :man_facepalming:

So if its a python library you’re after check integrations and failing that check HACS and the forum. You’re looking for an integration or custom component since those can depend on libraries from pip. If you really can’t find one then you can make one and then add it to your custom_components folder so you can then use it within your HA. If it works well you can even publish it to HACS or submit it as a PR to HA.

There’s another option, if you stick with HomeAssistantOS or the supervised install. It’s an addOn called “Custom deps deployment” and is available through the developer repositories in Supervisor.

With this addOn you can install PyPi packages in Supervisor. :slight_smile:

Hello my dears,
Thank you first for your answers. Unfortunately, I can only work on my project at night, hence the late answer.
My project is actually quite simple, but something always fails. The point is to switch a hot water pump on and off with a Raspi via a small transmitter with 433 MHz. Two more devices are to be added later, both of which communicate via 433 MHz. Ideally, a status check should be added later, which indicates the status of the devices to be switched. The whole thing should be controlled afterwards via an app that only we have.
Now it looks like I can’t run any additional tools and scripts with the standard installation of HAOS. On the other hand, installing HA on a normal Raspi is not exactly very beginner-friendly. I can already control the sockets using my own scripts. Actually, I “only” miss one possibility to bring the control to Android as an app
Maybe you have other ideas too.

sounds great. I`ll try it soon (Y)

I take it you are trying to use the Raspberry Pi RF - Home Assistant integration.

You do not need tp use pip to install anything. Just configure it and home assistant installs the rpi_rf module.

1 Like

the hint sounds great. Now I´ve installed the system complete new. Both (sender an receiver) are connected to the raspi. But I cant see it on the overview. What or which add on I should start that HA can see it?

It’s not an add-on. It is an integration and i have pointed you to the docs.

How can I check and establish that the HA has pulled and installed the scripts? I did the integration as described. The switch is now also displayed in the HA. GPIO is correct, the code is correct, but nothing happens at the socket. Is it possible to see a log file somewhere so that I know if something is going to happen?

You can see the log in the normal way. Via the gui or using ssh. You can also increase logging level.