Basic install not working on Pi4 2GB?

Hey Everyone!

I’ve finally gotten a test Pi for my Home Assistant installation. The main system has been running on a Pi4 4GB for more than 2 years and I was able to snag a 2GB Pi4 to start a ground-up rebuild of my home environment.

However, when I attempt to set up Home Assistant, the 2GB Pi doesn’t want to respond at all. If I hook up a monitor to it without any SD card installed, it will show the generic “No boot media available screen.”

But if there is an SD card, the screen is just black even after 30 minutes. I’ve tried BalenaEtcher, the official Raspberry Pi Imager, and two different SD cards; everything is the same each time. The red power light is solid and the green activity blinks quickly but dimly.

What else can I do to troubleshoot this install?

I don’t want to be the unluckiest lucky person to pick up a defective Pi…

Thanks for your help!!

Did you get the correct image for the SD card?

Yes, I did a fresh copy/paste of the image URL shown here when using BalenaEtcher. I also selected the generic 32-bit and 64-bit images using the official Raspberry Pi Imager. I even tried an external SSD drive. Every time had a blank black screen if there were any media available.

What other troubleshooting steps can I take? Is there a “really super scrub format this SD card” utility to make sure there are no conflicting boot-sector instructions?

Thanks again!!

If I start the Pi without an SD card and then insert the SD card, this flashes on the screen before going blank.

This is entering Greek territory for me. Thanks again for the help!!

Did you try any other image (i.e. a plain Raspberry Pi OS) Just to rule out it’s not a defective Pi?

So far I’ve tried:

  • Official image from
  • Raspberry Pi OS (32-bit)
  • Raspberry Pi OS (other) → Raspberry Pi OS Lite (32-bit)
  • Erase utility
  • Raspberry Pi OS (other) → Raspberry Pi OS (64-bit)
  • Misc Utility Images → Bootloader → USB Boot [result: green screen]
  • Misc Utility Images → Bootloader → SD Card Boot [result: green screen]
  • Booting with SD card
  • Booting with SSD USB drive
  • Booting with nothing then inserting SD card [shows stuff on screen then black when inserted]
  • Booting with nothing then inserting USB drive [shows stuff on screen then black when inserted]
  • Successfully booting Pi4 8GB then swapping drive to the 2GB Pi4

Essentially this:


Are there any other bare-bones boot utilities I can load to test out the Pi hardware?

Thanks again for your help!!

If no OS works then your SD card has issues.

I’ve tried two different SD cards and one SSD USB drive. All work with the not 2GB Pi but don’t work with the 2GB Pi.

Are there other diagnostic bootable tools that aren’t a full OS?

Sounds like a defective pi. You tried all options I’m aware of. One last shot; using any cooling? maybe a thermal shutdown.
Best Eric

I’m running HAOS and many add-ons on Rpi4 2GB for almost three years. Usually roughly 700 MB RAM is still free.

Yours is either defective, or the SD card is.

Not that i think it matters, but have you tried with a power supply, from 1 of your “working” PI4 ?

@erkr There’s no cooling attached, but it never got to a point to be even warm to the touch, always cool to the touch. I usually make sure the device is working before installing it into a case with cooling.

@boheme61 I’ve used an official Canakit 3.5A power supply and a USB-C cable from my laptop to power the Pi during testing.

Are there utilities like MemTest I can use to help diagnose the issue?

If it is defective, is it worth attempting an RMA with the current shortage going on? If so, would I just contact Adafruit about it?

Thanks again for all your help!!

ok, thou i did wonder if you have tried with another, but i guess the answer is No, unless you mean you actually tried to power the PI, from your laptop-usb port

Ya, I powered the Pi from my laptop USB-C port. I tried again with a battery backup power supply just to be sure but got the same results. :cry:

usb 2.0 deliver 0.5A , usb 3.1 09.A , … your backup-power , i have no idea … thats why my initial question was. Have you tried with another power supply that you use on a “working” PI … i don’t know how much a PI require, but if the “official Canakit 3.5A power supply” is recommended, i doubt it’s a good idea to “plug” this into a laptops usb-port.

I had the same issues when I did my install.
Turned out that the pi did not like 3 of my SD cards, even though they worked and tested perfectly. Also make sure to use a formatting tool like Sd format on the SD card and not windows format tool.

If a new SD card still fails, I would try installing raspberry os to see if it runs fine. This will help rule out the pi as the issue.

Using a power adapter lower than 3.5amps on a pi 4 is not recommended by the manufacturer.

Would a USB drive boot more reliably in that case?

Other than the erase utility on the Raspberry Pi Imager tool, what are good SD card wipe apps (preferably that can run from Windows)?

Thanks again!!