Basic Installation of

I’m very confused about basic, first time installation on a new RPI. Following the “Installing” instructions exactly, I downloaded the image for an RPI 3, then flashed it to a 16GB Class 10 SD card with Etcher. Noting that the WiFi setup section is ‘optional’ (even thoughI don’t see how can possibly be true), I put the SD card in the RPI and booted it. After the usual short delay I get the HA splash screen and that’s it. I waited much longer than the suggested 20 minutes, then tried to access the installation at http://hassio.local:8123 as per the docs. It times out with a DNS error (of course it does; the RPI can’t even get an IP address from DHCP without being connected to my local WiFi and there is nothing to resolve that name even if it had an IP!).

Backing up, I edited the system-connections/resin-sample file on the SD card to supply the SSID and PSK for my home WiFi setup. Again, the system boots and displays a splash screen but nothing else happens. I can see sporadic disk activity on the card. My DHCP server never sees a request for an address from the RP3.

Backing up again, I supplied a static IP for the WiFi connection and tried again. Same exact thing – boots, splash screen. TIny amounts of disk activity. IP address I assigned in not pingable. URL of http://:8123 is not reachable (it times out).

Honestly, this is the recommended way to get a Home Assistant server going?

I’m not sure what to do next.

To check you ended up at this guide, and set up the WiFi accordingly?

The WiFi setup is optional if you use a wired network connection, which is recommended.

Yes, that’s exactly the guide I followed. I’ve just tried things again with a wired connection and no configuration which produced the same result – the device is not reachable.

Just out of curiosity, how is this supposed to work? The domain name in the URL http://hassio.local:8123 is being resolved by what exactly?


Odd, if it doesn’t work with a wired connection then it suggests a deeper problem.

The .local domains are resolve through multicast DNS.

It might be worth popping over to the Discord chat and asking in the #hassio channel. The folks there should be able to help you work out what’s going wrong for you (it normally gets the most experienced folks from about 8 to 12 hours from now)

It might be worth noting that I had to look up the address of my Pi and type that in rather than the “local.hassio” they recommend. And that worked for me. Though yes I suppose you should be getting an address in the first place which a wired connection should under normal circumstances give you.

Part of the issue here is that I use .local for my home domain (and run my own DNS servers to service the domain). I know that using .local has been deprecated since it became a “thing” for multi-cast DNS in 2013, but I’ve been using .local for my home since around 2000 and it’s embedded too deeply within my HA environment to expunge it now. This is the first time I’ve come across a conflict.

No matter what I tried, I could not get wifi to work even with statically-assigned IP addresses, so I backed up to the beginning again and used a static IP on eth0 – and that worked.

I have a number of additional questions, but they’re not related to installation, so I"ll let this thread go.

Thanks for the advice along the way!


You might be giving a fixed ip that already exists in the network. And remember that is a headless server, you won’t be seeing anything on video output except the HA logo. To access HA use another computer on the same network and browse to http://