Basic lighting control in Home Assistant - going around in circles

Ok run into a wall.

While addressing an issue of zigbee2MQTT failing, suspected over load/hue bulb issues, I am moving 80 odd hue lights back to 2 Hue hubs to stabilise things and also get some stability back and stop annoying my wife when zigbee2MQTT crashes leaving her walking into a dark room.

So moved (about half) the lights and now updating existing Home Assistant automations.

I am trying to work out how set a Hue Bloom light in the Hue integration to Red 20% brightness, or Green 20% brightness.

I can see a way to turn on or off the light.

I can see by using scene I can set the brightness.

There must be a simple way to do what I need.

Any guidance?

- service: light.turn_on
    entity_id: light.your_light_here
    brightness_pct: 20
    color_name: red
- service: light.turn_on
    entity_id: light.your_light_here
    brightness_pct: 20
    color_name: green

See the other data options of this service here:

Many thanks.

Does that mean the only way to control the light is by getting into YAML scripting?

I am ok with that, if it can’t be done using the UI, it is what it is.

I have just started today getting YAML. I will use Node Red if necessary until I can figure it all out.

No, you can call any service from the Automation editor.

I have added to YAML

Each time I saved the changes it lost the changes.

Tried three times each after saving it lost the changes.

So copied it all to Studio code Server, edit it there then copied it back after deleting the existing YAML, one char at a time as there does not appear a way to select all and then delete :frowning:

It won’t let me save as there is a dictionary error?

No idea how to fix that.

Thanks for the help, I’ll try doing it in Node Red.

As I said, you don’t need to use YAML. The automation editor can make service call actions.

However your issue is that you have not indented entity_id under target in the light.turn_on service. Look at what I wrote in my example above.

Ok getting there - those pesky invisible spaces !!!

I think I have the Yaml fixed


I found the Then do Lights/Turn on option, I had been thrown by the choose area/devices/entity/label options

Once I had that just need to work out how to set the colour - had expected a colour wheel but figured it out.

I have moved 40 odd Hue Lights and ~10 motion sensors and hopefully that reduces the zigbee2MQTT workload enough for it to stabilise and not just loose every devices every 5-7 days

Thanks for your help again