Basic set up advice for Zigbee, MQTT & Sonoff dongle

Tried last year to get going with HAOS and failed. I have HA installed on mini windows PC with Ubuntu.

I have

CC2652 by Texas Instruments
Firmware: Z-Stack 20221226 plugged in to my PC (I think I flashed it last year with a software update)

MQTT installed - this is showing 9 entities and one device. There is reference to Zigbee2MQTT Bridge deeper within

However under Settings>Integrations tab Zigbee Home Automation is in a red box with Failed Set Up - Will Retry showing. If I select re-configure from the three dots menu it says “ZHA will be stopped - Do you wish to continue”

I am not sure which dongle I have got. I think it is dongle-P. details copied from Amazon buying history at https://www.amazon.co.uk/gp/product/B09KXTCMSC/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1

  • Pre-flashed with Z-Stack 3.x.0 coordinator firmware
  • Can use ZHA in Home Assistant or use Zigbee2MQTT
  • Base on TI CC2652P + CP2102N

Can you advise on trouble shooting advice please.

Not quite clear…

Have you got both the ZHA and the Z2M integrations running at the same time? You can only do that if you have a separate dongle for each of them.

If you’re using ZHA there should be no reference to Zigbee in MQTT (in fact you don’t need MQTT at all unless you’re using it for something else); if you’re using Z2M you should disable the ZHA integration.

2 Likes

Zigbee Home Automation sees your dongle, but does not know it is already used by Zigbee2MQTT. So, if you want to use Zigbee2MQTT, the best thing to do is remove, the second best disable.

2 Likes

Thanks for the reply. The main reason that I think that I will need MQTT is that I hope to get Frigate working and think that MQTT is needed for this. I initially hope to install powered smart switches and plugs across the house to allow the Zigbee mesh to develop. Then battery powered sensors can connect to that mesh.

I am not sure if ZHA is running, I’m away from home currently - I’ll look when I get back and try to disable it.

Hi Francisp, Following on from Stiltjack above I think I have disabled then deleted ZHA.

Did a re-start

Now in Settings>Devices&Services I have in Discovered the following

image

Then below I have

image

clicking on MQTT I have the following

image

and clicking on the 1 Device I have

How do I get my dongle now working with MQTT?

thanks Fergus

Click on Ignore
afbeelding

and restart Zigbee2MQTT

1 Like

Dear Francis,

THANK YOU SO MUCH. I know that this is so basic - but you and @ Stiltjack have got me going with my first thing in Home Assistant! I started a year ago, gave up and put the project to one side and did nothing. However with answers to this recent question - you have got me going and given me the confidence to pick up this project and get re-started again. :slight_smile:
image

So now I have the Zigbee MQTT running and got my first Smart Plug working - I can switch this on and off with my Companion App or via the browser. I am very happy! Now I need to learn adding this to a dashboard and use the information it supplies.

Once again - thanks for your support. Fergus

1 Like