Basic Z-Wave confusion - moved to new house, nothing works

I suspect this is more of a basic “I do not understand z-wave” question than home assistant but any guidance would be appreciated.

For years I had a dozen or so z-wave devices working fine, mostly Zooz 4-in-one sensors, with three Aeon range extender 6’s. I use a separate rPi with zwavejs running (since HA is in a HyperV container with no usb access). All working perfectly.

Then I moved. To move I just took down all the devices, shut down the rPi and HyperV server, and moved. At the new house I used the same subnet and everything came up and was running except the zwaves.

The zwavejs UI works, and I can ping the range extenders, but none of the battery powered devices are responding. To be sure it’s not a distance thing, I brought them all into a spot about 20’ from the controller, and quite literally surrounded by the range extenders, and left them sitting over night. Nothing. Can’t ping the zooz devices, I CAN ping the range extenders. The zooz devices all show last activity date before the move.

All the batteries were fresh (mostly, showing 100%) before the move, but I swapped one’s battery just in case, and on several I power cycled them. Still nothing after a few hours (total time testing is now about 16 hours).

I feel like I’m just missing some basic step. In the past changes (e.g. replacing a battery) may take a few hours to show up, this is much longer.

The software is a tad out of date, I stopped updating when I started packing for the move. zwave-js is 12.3.0 and HA is 2024.2.1 (which I suspect is not really involved as I am troubleshooting on the zwave-js UI).

If I view statistics (in the zwave-js UI) from these devices there is no data shown. The log doesn’t show anything that is helpful, at least to me. Here’s a snippet that shows me trying to ping node 3. Note that the neighbor lists are showing from non-responding notes, but I think that just comes from the controller, they still show no activity.

The only thing that may have changed is I do not recall which USB port had the controller before, but since it can ping the mains powered devices I assume it is working. The rest is all the same hardware just picked up and moved.

Any thoughts or advice?

Am I just impatient? Does it really take more than 16 hours?


Its probably “working” but having a heck of a time.

ZWave is a mesh of devices that repeat for each other. But that only works if they keep a map of thier neighbors in range so they can talk.

What happens if all of a nodes neighbors are suddenly out of range? That node becomes an island and can’t talk to anyone, effectively cutting it off. - - - even from repair / routing requests. (this is the problem)

If your first hop nodes are no longer where they were and have comms problems so will everything down the chain.

So you need to focus on repairing your ZWave network. Starting with the nodes closest to the coordinator stick. In some cases. It might just be easier to exclude and re-include.

But once you have EVERYTHING back on line and pinging at least. You are probably spending a LOT of time in the console running ZWave repair to make sure the reputed are fixed. In the new home pay attention to where you may need more repeating devices.

So when the controller was powered up all the devices were at the other end of the house and (likely) out of range, and the individual zwave devices travelled in the moving van powered up (in retrospect perhaps a mistake).

At this point they are all (but one, for control purposes) easily in range of both the controller and the range extenders.

Is there something I need to do to encourage them to repair themselves? Asking a node to repair its routes when I can’t ping it seems unlikely to work. To your “Focus on repairing… starting with the nodes closest”.

Yes, I could reset them all to default and delete and re-add them I guess. But everything was present and working was hoping to just leave as-is (in terms of names, HA devices, which are linked to a lot of automations).

Battery operated devices sleep when they have nothing to tell. So you need to wake them up as per the device manual to be able to ping them or ask them to heal.

1 Like

For orphaned nodes

Two choices

Either you have to repair the nodes it thinks it can talk to before it will start listening. (that’s the entire repeating chain from the coordinator to the device)

Or. You exclude / reinclude the trouble node.

If you use option one repairing your nodes from coordinator out (use the map of the old house.) and eventually everything should start to open up once you get a few key repeaters back up.

But if you don’t have that info about what was where you may be to just reinclude a device.

I think a critical question to ask before deciding how to move forward is “do you know the node numbers of your physical devices?” If you have a device in hand, do you know what it’s node number is? If the answer is no, I personally would exclude and re-include them. If the answer is yes, you should be able to find the repeater(s) that was its neighbor. Get that device close to that repeater, wake it up and ping then heal it. Keep in mind it might be the controller and not a repeater.

I personally make it a best practice to label every device with its node number. Once you have many of them it can get very confusing.

1 Like

So this is a bit bizarre, but one mystery is solved.

ALL of the batteries were dead. Something about the move, maybe motion, lack of a controller. Dead.

I had swapped one battery just in case, and I must have done something wrong. When a new battery is inserted it flashes a little rainbow sequence, so I could confirm (once I saw that) that the old one was dead (no sequence). When I swapped one I did put a good battery in (fresh from the package) but do not recall a flash. Maybe I just failed to get a good connection.

But once I replaced all the batteries and did a wakeup, they all updated directly to the controller.

To @mterry63 question, yes, I have them all labeled so I know the node numbers. What I do not know is the topology that was working. When I view neighbors now they all show direct connection to the controller. I THINK they may have been doing that in the old house also (small house, central controller; I bought the repeaters just in case but never paid attention because everything worked).

Now I just need to move things around, maybe force some routes.


Batteries got drained lightning fast, because devices were constantly looking for network during the move :wink:

1 Like

Don’t forget to mark your post as the solution - it makes it easier for others in the future searching for similar problems :wink:

I think I hate z-wave. I’m sure I do not understand it.

Apparently it is doing some kind of trial and error for building a topology, every 30 minutes or so I look and it’s quite different, some that make sense, some that do not. But I guess as long as it’s happy.

Is there guidance somewhere (or can someone share) when one should be running the options under advanced, like rebuild routes? Every time I run it, it shows failed (well, it usually shows the API succeeded but then has a failure icon). Maybe I just should not mess with it.

At any rate, I think my core problem was somehow devices with 100% showing as battery rode around in a box for about 4 weeks and then had stone cold dead batteries. Good thing I had ordered a big pack of them for the new house. Sorry for the tangent.

First. Think freight train. Not Sportscar. This is an ULTRA low power and low bandwidth network. Things take time and it’s very VERY easy to saturate. When you grt things moving you need to step back and let them finish else get run over.

Run one node repair at a time. If one is running and you request another it (the second) will fail as you describe.

If you’re using JsUI you can keep the console open and watch (heck when Imdoing routes I just open the debug window and let it run in a corner of my desktop. When it stops scrolling I fire the next repair.)

Also never ever fire the repair entire network unless you know EXACTLY why you’re doing it. Your network will basically be useless until it’s completely done. You’re better off targeting repairs and once everything is talking step back and let it settle.


Well, freight trains are pretty powerful… but I take your meaning.

How about “Slime mold”. If left alone long enough, they can optimize a path through the streets of Tokyo (literally, google it) using almost no energy and obviously very little intelligence.

Yeah… Z-wave = Slime Mold. Now I understand. :wink:

PS. “unless you know EXACTLY why you’re doing it”… good thing I didn’t know there was a “repair entire network”. Now I know. See what risk you take by mentioning it? It’s like “Never push the red button”…

PPS. Thanks for all the help.

1 Like

You’re welcome… And really don’t push the red button…

1 Like