Beelink Nobody Cared error

I am running HAOS on a Beelink U59 (or trying to). ever since i got the box in December 22 I have no been able to keep the system up
I just tried 10.1 and same thing
I get the message
Irq 16: nobody cared (try booting with the “irqpoll” option)
Azx_interrupt [snd_hda_codec]

Trying to setup this system to be the most performance and cost effective with the pi shortage. Have run other beelink pcs before and work great. Recommended this to a friend and it crashes. Maybe a different beelink? I dont want to make kernel adjustments as that will break with each os update

I have even installed Debian and supervised. I don’t get an error but docker dies on it during the restore of my backup.

That is the direction I went. Some mini’s use some no-standard HW that might cause problems with HAOS. Debian is a well beaten path. Laptops also sometimes use HW that is not widely used, not bad just not a well beaten path.

Thanks Tim, still having some issues with the two systems. I can’t seem to do my restores. Will continue to play. Debian seems better and I can disable things in the kernel that aren’t behaving.
Not sure what system to recommend to my friend to use for Frigate and HA - he is running both on a Synology but not much RAM left to do other stuff :slightly_smiling_face:

@ian3 , did you resolve your problem regards Azx_interrupt issue ?
I’m running 10.1 on a Beelink and getting the same errors.

No, using a different box
I think Proxmox worked ok but I wanted bare metal approach

I think the only way is move from HAOS and using a Debian.