Beginner all over again - groups

I had HA setup and running for a while but then drifted off. Now that I have all sorts of free time on my hands I am coming back to it. I downloaded the OVA and have it running with 0.111.3. I have it connected to various items in my house again, not much of an issue there.

I am now trying to re-learn some of the basics and have to say that I am really struggling. I’ve spent a bunch of time searching but I am (likely AGAIN) not having much luck.

For all intents and purposes other than adding things like my ISY I have a default install from the OVA. I am trying to work out the basics before I do much. What I am struggling with right now is Groups.

I have created a group in the groups.yaml (config checks are all good):

  name: test1
    - switch.playroom_light

I have created a simple automation in the automations.yaml (originally thru the GUI but repurposed doing by hand):

- id: '1592275654013'
  alias: Test
  description: ''
  - entity_id: switch.playroom_fan_light
    from: 'off'
    platform: state
    to: 'on'
  condition: []
  - service: switch.turn_on
    entity_id: group.test12

When I turn on switch.playroom_fan_light I see in the logs that the automation is triggered but the light in the group does not turn on. If I simply put the device directly in the automation it works as expected. I have tried switch.turn.on as well as homeassistant.turn.on, neither works.

I would also like to have the group visible but when I add view: true (or yes) to the group the config throws an error.

I am 100% sure that this is something I am doing wrong but can’t figure it out.

I assume.youll be putting more than one the group ? To turn a group on you need the homeassistant.turn_on service and not switch.turn_on, that’s just for switches

Also your name is not test12 it’s test1

1 Like

Yes, will add more things, just minimizing my investment in time to get it working.

I changed back to homeassistant.turn.on and rebooted and that seemed to have fixed it. I guess maybe I wasn’t waiting for the reload to happen before when testing that.


oops, related - the group does not show up in the UI, how do I make that happen?

Not sure what you mean, where in the UI ? If you mean in the frontend, it wont be there until you add it

yeah, in the front end UI. Once I define the group it doesnt “show up”. How do I make the group show up?

You’ll need to add an card and then add the entity. If you’re new to lovelace, I’d look at the docs to get you started.