Beginner needs support

Check the router’s web interface to see what the WAN IP is, then compare that to what you see if you use on of the what is my IP services.

Most mobile broadband providers don’t provide you with a publicly accessible IP address, but use either CGNAT or private IP space. If you’re not sure about yours, post the first two sets of numbers (eg 100.64.x.y) and we can tell you.

The IP is and router settings page give same IP number.

Contact a forum moderator to purge the history of one of your posts. It’s the post where you revealed your DuckDNS information. Deleting text from the post does NOT make it inaccessible to the public.

Look at the upper right-hand corner of the post and you will see a number and a pencil icon. Click it to reveal all the changes you’ve made to your post, including the DuckDNS you deleted (and thought no one could see anymore).

Ok, got the point. I will change the duckDNS address and token when issues are fixed.

WOW I finally managed to access the HA remotely!!!

Problem 2 and 3 fixed!

Thank You!!!

So 1 more issue to cover under this topic :smile:

Did you configure the Tasmota device to publish to your broker?

Have you installed a client, like MQTTfx, to check to see if it’s publishing to the broker?

I moved the HA under ISP router, but the Tasmota device was under other router, that is behind the switch. Tried to change the SSID and pass, but it does not connect to the ISP router. Had to flash it to try again, but no success. It just does not connect to this router. Both wifi networks have WPA2. Will try one more time flashing it.

Is there a way, I could get my own router to work in a way, that it is the same network as the ISP router, but has separate SSID and pass?
Connected with cable like this: ISP router - 16 port switch - my router

Can not remember what and how I did it, it was 3 weeks ago. Try to get the NodeMCU in the network, to give more details.

stop using 2 routers as routers.

Yes. You use your router as an access point and switch, not as a router. A router routes traffic between networks. You have 2 disparate networks and are trying to figure out why things don’t work. They don’t work because you have 2 disparate networks.

You only need ONE router on your network.

I understand. I just can not figure out myself how to do this. For all situations until now it was enough to just connect and configure wifi.

How to get rid of the router function? Disable DHCP server? What walues should I then insert?

The ISP router IP address series is 172.16.x.x

On some routers, you can enable ‘AP’ mode which usually will turn the routing functions off. If your router doesn’t support that, it’s pretty easy to handle.

Disable DHCP on it

Set the INTERNAL IP of the router to one on the network you want to use (make sure it doesn’t conflict with any other device on the network)

Plug a cable into your LAN port on the main router or switch, to a LAN port on your “AP” router, not the WAN port.

Configure your SSID…That’s it

I understand, it must be the same serie that is the ISP router? 172.16.1.x?
All current devices in the ISP router:

if i set the IP is this ok?
If I am totally wrong, I will paste screen shot of the AP window and you tell me what to fill in :sweat_smile:

The same SUBNET. Yes.

I don’t know. What is your DHCP scope on your ISP router? You want an IP outside of the DHCP scope

Got it up and running! The AP (my “router” :grin:) changed the IP addresses itself after some time, after switching off the DHCP server.

Got the tasmota device also working, and sending data to HA with MQTT. I have a car parking sensor connected to NodeMCU and sending distance information to HA. Found how to display gauge make it update as often I need.

I think we can call this topic finished and all 4 problems solved! Thank You hor help!

Should I make my next steps and ask support under this topic, or create separate posts? My 4 issues got answers. But here it is easy to follow up what is set up already and what I have done in the past…

Check the solution button on the post where your problem was solved (helps others) and probably better to start a new thread with a descriptive title…

Best, generally speaking, to have a thread be about a single problem.

My issues were all related to 1 problem - me :innocent: