Beginner needs support

Hello everyone!

I am making my first steps in HA. I have a Raspberry Pi 3 with 64Gb card. Network is cable connected.
I tried to install all according to video tutorials and written instructions, but there are many things, that probably have changed since the videos and written instructions were made.

My plan was to follow the instructions of JuanMTech, and then start to add Tasmota based devices and other into the system and learn on the go. But had difficulties installing
1)Samba (the folder does not appear in Windows computer); fixed
2)DuckDNS is up, and log ok, but can not access HA from outside network; fixed
3)I am nto sure if i did all right with my TP-Link router with port forwarding; fixed
4)installed Mosquito MQTT, but probably messed up something, as I can not see the tasmota device in HA. fixed

I was ready for few issues, but as I do not understand 100% what I am doing, I probably just miss the smallest step…

If someone is ready to help me fix my faults, let me know what part to start with, so I could tell more where I got stuck, share screenshots and code.

Sorry, If I misplaced the post under wrong category.

Thank You!

Well, you didn’t put it under any :wink:

Please take a read of the sticky post. This explains how to help us help you.

Then, pick one thing and start by tackling that. Trying to solve multiple problems at once rarely works well.

Well, yes, videos age fast. Home Assistant is updated every 3 weeks. The official documentation however doesn’t suffer from this problem :wink:

Maybe lets start with samba :wink:

Did you try manually mounting the share in Windows?
Are you using the hassio addon for samba?

So problem no 1 - Samba

I can share details in the evening (My time zone is GMT+2).
I installed Samba with hassio addon. Played with all kind of network settings in win 10, to get it working. I need to change the Win OS language from Estonian to English for all to be clear. I think the issue is in Windows, not HA, but we will find out :slight_smile:

At the very least, you should be able to use the IP for the connection, for example:


this is working!

but no network folder

I now created manually a network folder \\shared
and \\config
I had to pick a folder, it refused to create without subfolder.
But if i click on the ip address in address row, I can go out from the sub folder, and access all folders and files.

I think we can call it fixed?

Problem no 2 and 3! DuckDNS and Port forwarding

In Router: a)I have fixed the IP address and MAC address under Address reservation.
Router settings have topic Forwarding that contain sub topics: Virtual servers, Port Triggering, DMZ, UPnP. Where should I enter the ports? I did put under Virtual servers, but now i think I should try UPnP :blush: Please help with directions

You should never rely on Windows to present you the proper network shares, and always manually map them.

You don’t want UPnP…Do not do that.

This depends on your router. Look at Port Triggering…what options are there?

Virtual servers

The portforward site can help you with your router.

My suggestion is:

  1. Set up the port forwarding
  2. Test it with this site to ensure that it’s reachable
  3. If it works, then set up SSL

I looked at the site yesterday. My router is not listed, but similar model, with same software I found: According this site, I picked Virtual Servers.

Current status, where I left it yesterday:

And under Port Triggering I have one more time 443 - 8123 set. Confusing was, that all the other routers in the HA instructions had a place to write the “name” of the port setting, mine takes only numbers.

This Open Port Check Tool tells, that all ports I test are closed!

If I am giving out some data, I should not because of network safety, let me know, so I can fix it :smile:

DuckDNS Log (I restarted it few minutes ago, to show startup log).

# INFO: Using main config file /data/workdir/config
+ Account already registered!
[21:25:21] INFO: OK
# INFO: Using main config file /data/workdir/config
 + Checking domain name(s) of existing cert... unchanged.
 + Checking expire date of existing cert...
 + Valid till Jan 11 05:41:49 2020 GMT Certificate will not expire
(Longer than 30 days). Skipping renew!

Should I post Log info “like this”, or normally, and only code “like this”?

You gave out your duckdns URL, but it’s not accessible, so something is broken. :wink:

I just edited my last post: This Open Port Check Tool tells, that all ports I test are closed
So I guess, something is wrong in the router settings. Incoming and Trigger ports are these right? Right number in right box?:sweat_smile:

My configuration.yaml file has only 17 rows filled with code (including DuckDNS HTTP ). If I look samples, they have ca 80 rows.

You tested port 443? (I did anyway, since you’ve left your domain showing, and it is closed)

Until that works, ignore DuckDNS (back to the solve one problem at a time).

Things to check:

  • You only have one modem/router device
  • You’re not using a mobile broadband provider (3G/4G)
  • The WAN IP on your modem’s admin pages matches the IP (IPv4) you get from a this site

So now we found the issue :innocent:

I have a router provided by ISP. But as they change the routers and upgrade firmware minimum once per year it is better to keep my home automation under another router, where the SSID and IP-s never change. So I have the ISP router + my router. My router is working in router mode (not switch).

I am using 4G router. What to do now?

I can solve double routers, by changing my own to switch mode? Or is there other ways?

The solution here depends on a couple of things, but the biggest thing is the bit you didn’t answer…

  • The WAN IP on your modem’s admin pages matches the IP (IPv4) you get from a this site

Your WAN IP may either be CGNAT or RFC1918 - both of which basically mean nobody else can reach your system. Posting either the first two sets of numbers (eg 100.64.x.x) or confirming that they’re either the same, or not, and then we can help you move forwards.

If you are remotely accessible, the simplest solution is to put the ISP’s modem/router into bridge mode so that it’s just a simple modem. You can also simply port forward from the ISP device to your router, then again from your router to your HA system.

If you aren’t remotely accessible then the simplest option is the (paid) cloud service. This, amongst other things, allows your system to be remotely accessible without any port forwarding, SSL certificates, etc.

Just had 2 hour conversation with ISP support. For some reason I was not able to access my ISP router IP address. Finally after resetting all devices, I could access it, but the user and pass does not work. I gave up. They told, I have to access the outside device, that is mounted 5 meters high on the wall (pass is written on this device outside as they told).

Try to ask the ISP support to confirm the IP-address tomorrow.

The site gves my puplic IPv4 85.29.x.x

My own router supports DDNS ( No idea how it works. Is it same as DuckDNS?

Hold on.

You state that you have an ISP router and YOUR router…If all you are doing is forwarding ports in YOUR router how does the traffic know it’s supposed to be opened up in the ISP router? If you are double natted (running a router behind a router), that would be why it doesn’t work. You need to forward the port on THEIR router to YOUR router, then in YOUR router forward the port to the server.

It doesn’t matter. Yes, it works similarly, but no-ip won’t handle the certificate like the duckdns add-on does.

It has been rining alot recently and it is dark already when I get home. Today had finally time to take out the ladder and seek for the user password for ISP router (it is 5m up on the wall outside) . I can now access it. Try to get rid of the double routing try to forward the ports on the ISP router. Takes some time, as I need to remind all the steps :sweat_smile:

I now made some changes to my home network. System is set up like this: ISP 4G router (has only 1 port to connect, after this comes a 16 port switch, and my own router is plugged int the switch. The HA is connected to the switch, and the the IP for HA is reserved in ISP router. So no double router issu any more. Unfortunatelly I can not find any documentation for my router or .
The port forward page looks like this:

will try to play with this in the evening, not sure what values to use.