Beginner's issue with CustomUI

I’ve added to my config :

homeassistant:
[...]
  customize_glob:
    "sensor.*":
      show_last_changed: true
      custom_ui_state_card: state-card-custom-ui
    "binary_sensor.*":
      show_last_changed: true
      custom_ui_state_card: state-card-custom-ui

customizer:
  custom_ui: hosted
[...]

and I am getting after a restart

2018-07-19 00:34:46 ERROR (MainThread) [homeassistant.loader] Unable to find component customizer
2018-07-19 00:34:46 ERROR (MainThread) [homeassistant.setup] Setup failed for customizer: Component not found.

What have I missed ?
Thanks !

Not sure why, maybe because you have not added the extra_html_url bits to your config?
I guess you’re trying to achieve the same results as me, here’s how I did it:

Merci @lolouk44,
yes this was from your configuration.

I’ve also tried to add :

frontend:
  extra_html_url:
    - /local/custom_ui/state-card-custom-ui.html
  extra_html_url_es5:
    - /local/custom_ui/state-card-custom-ui-es5.html

but I’ve got empty cells in the the Hass frontend,
I’ve done a github search to see if that was the right syntax for a hosted CustomUI via https://github.com/search?l=YAML&q=custom_ui+hosted+frontend+extra_html_url&type=Code but I can’t find the syntax.

I’ve also read the docs under https://github.com/andrey-git/home-assistant-custom-ui/tree/master/docs but didn’t find what I was looking for…

So you’ve followed the instructions on Andrey’s page right? You’ve done the local install and local activation:

You’ll need to restart HA and refresh your browser. You may also need to clear your cache (this was my issue)

thanks - do you know where can I find the remotely hosted installation method ?

it’s not clear on https://github.com/andrey-git/home-assistant-custom-ui/blob/master/docs/installing.md#hosted-use-ha-053 if we need to update.sh for the remotely hosted method.

if it’s hosted, there’s no installation, you need to use the URL of the files hosted on Andrey’s page:

HA 0.59+

frontend:
  extra_html_url:
    - https://raw.githubusercontent.com/andrey-git/home-assistant-custom-ui/master/state-card-custom-ui.html
  extra_html_url_es5:
    - https://raw.githubusercontent.com/andrey-git/home-assistant-custom-ui/master/state-card-custom-ui-es5.html

thank you ! if I add this - and yes it was on https://github.com/andrey-git/home-assistant-custom-ui/blob/master/docs/activating.md - then I’ve got my ‘last changed’ data added to the cells, so this is very good

But I get one issue when I run --script check_config

General Errors:
- Component not found: customizer

It’s also showing on the web UI.

not sure to be honest. I’m using the local version, not the hosted…

i’m using the local version, and have the basic custom ui state cards showing (just using the show last changed option for now).

there is supposed to be a new option in the home assistant configuration for custom UI tweaks, but it does not show up automatically. i’ve restarted home assistant, cleared cache, restarted browser, and still not there.

how to i get the ui component for the custom ui tweaks? currently running 0.79.2

whoa, weird. after restarting about 3 more times playing with reorganizing some groups and adding in some lights into a group i forgot to add yesterday, the custom ui tweaks just magically appeared in the configuration panel. strange as i see there is nothing in the logs saying anything is different

even stranger, this is all i get there. is there supposed to be more?

Had a few issues after 0.78 (I think) and ended up giving up and using Lovelace instead as all I was using custom-ui for was the last changed additional line which lovelace does by default/as standard

i think i misunderstood the purpose of the device name field. after reading the docs a couple more times, i think this is so you can setup a device name on each instance you log in with HA on (phone chrome browser, desktop browser, etc) and can then allow that device name to be used with custom attributes?

i really wish there were more front end configuration controls. i know it will come, but having to configure everything in text files (whether it is frontend, custom-ui, lovelace) is a bit annoying. totally works, but annoying