Benoit Anastay Add-on: Paperless-ngx

Benoit Anastay Addon : Paperless-ngx

GitHub Release Project Stage License
Supports armhf Architecture Supports armv7 Architecture Supports aarch64 Architecture Supports amd64 Architecture Supports i386 Architecture
Github Actions Project Maintenance GitHub Activity

Paperless is an application that manages your personal documents. With the help of a document scanner, paperless transforms your wieldy physical document binders into a searchable archive and provides many utilities for finding and managing your documents.

Installation

The installation of this add-on is pretty straightforward and not different in
comparison to installing any other Home Assistant add-on.

  1. Click the Home Assistant My button below to open the add-on on your Home
    Assistant instance.

    Open this add-on in your Home Assistant instance.

  2. Click the “Install” button to install the add-on.

  3. Start the “Paperless-ngx” add-on.

  4. Configure the add-on (Documentation)

  5. Check the logs of the “Paperless-ngx” add-on to see it in action.

Get help

Feel free to ask for help in this thread, also you can open an issue if you encounter a bug of if you need new features

Roadmap

For the next release those additions/updates are planned

  1. Allow auth from Ingress
  2. Add apparmor.txt file
6 Likes

Thanks so much for making this updated addon. Any plans for SSL support? Much appreciated.

I was working on it yesterday, my deadline was the 5th but my laptop wasn’t powerfull enough to rebuild the image

server {
    {{ if not .ssl }}
    listen 80 default_server;
    {{ else }}
    listen 80 default_server ssl http2;
    {{ end }}

    include /etc/nginx/includes/server_params.conf;

    {{ if .ssl }}
    include /etc/nginx/includes/ssl_params.conf;

    ssl_certificate /ssl/{{ .certfile }};
    ssl_certificate_key /ssl/{{ .keyfile }};
    {{ end }}
}(https://github.com/BenoitAnastay/paperless-home-assistant-addon/compare/main...ingress#diff-ac6e0dcab49d60e53dd7357527acfbcaa9bf8d14d08f5d9cef3a5a5212274028)

On my Installation I use Nginx proxy manager to manage SSL, I disable the addon port and use the local addon hostname in nginx proxy manager, I plan to make a authelia add-on and make a tutorial on how it works all together

I am also using NPM for SSL but yeah adding Authelia in the mix would be cool!

So I’m 3 days late but v1.1.0 is now released.

For the moment ingress and direct access cannot work in parallel, ingress also need URL to be defined

What’s changed

:sparkles: New features

:rocket: Enhancements

:books: Documentation

2 Likes

Hello , first of all thank you for the great HA-Addon . I have a question, I wanted to create a sensor in HA via the Rest API. However, it is not clear to me which port to use. In your github documentation (README.j2) it says resource: paperless.server:port/api/documents/ . In the log of the addon I see e.g. port 8000 and port 8001 . This has not yet worked for me at least. Probably i am missing something ? Another question is whether it is possible to configure other parameters? In the documentation of paperless ngx there are quite a lot of additional parameters. Can I set them somehow via the add-on ? Many thanks :slight_smile:

Currently you’ll have to enable a port on the configuration tab to be able to use the API
You can still use it trought the docker network with its hostname ca5234a0-paperless-ngx

1 Like

Thank you very much, that was exactly what i apparently didn’t see :blue_heart: :grinning: :+1:

Thanks for this addon. Is there any options to run the document_rename process in some automation? Because paperless names the document at first import but dont change it if i change the metadata.

It’s documented there https://docs.paperless-ngx.com/advanced_usage/#storage-paths

Hi Benoit :),

nice Add-on!
Where I can change the config? I’d like to add following:

PAPERLESS_TIKA_ENABLED=true

Thank you very much!

BR

Hi Benoit,
at first I must say that you did great work. !!
Is it possible to change the Path to the media folder to a shared network (cifs) path?

As I explained in another thread you just need to create a share named paperless in HA OS it will be mounted to /share/paperless then because inotify doesn’t works on shared you need to set a pooling interval in the add-on configuration tab

In paperless.conf located in addon_config folder

Also I will have difficulties to update the addon this week but I continue to maintain the addon, ppl are also free to help by making PRs

Hello, I have to add my voice to this question. I have tried to create a CIFS share on a Synology NAS. That works so far. The directories are created in the share folder. But the add-on gives me the message that the rights do not match.
ERRORS:
?: PAPERLESS_CONSUMPTION_DIR is not writeable
HINT: Set the permissions of
drwxr-xr-x root root /share/paperless/consume
I have set user and group to 1000:1000 on the Synology NAS (via ssh shell command) with chown. However, the problem persists. If the permissions do not match, why can a directory be created in the share at all? Consume and Media are created without any problem. You wrote in another post that this worked with your NAS share. What permissions do the shares have and which GID and PID are used? Please excuse me if I ask again, but maybe you still have an answer. Thank you very much for your great work.

I do not have ACL on my share but you can maybe try to run a chown command from Home Assistant

Hi, i am trying to connect the app “Paperparrot” (iOS) with your addon on my home assistant. But no matter what I am trying, it won’t work.

i tried: homeassistant.local:8000, homeassistant.local:8001. I even set a custom URL (homeassistant.local and my duckdns-url) in the configuration. The app only quits the login attempts with “no connection possible” or “405” or “404”.

Does anyone know what to do?

You will have to enable a port for direct access in the add-on configuration tab

We cannot bypass home assistant authentication for ingress

Hello,

is it possible to manually run the tasks like “document_create_classifier”?
In the older versions you could run the tasks in the admin interface. Cant seem to find the option now.

Thanks in Advance

You will need to open your host shell and use docker exec to run a command into the add-on

You can maybe add a button to your home assistant as a shell command to have a shortcut

https://docs.paperless-ngx.com/administration/#retagger

1 Like