Beok (Tuya) WiFi Glass Thermostat (new one) not integrating properly (tried Tuya and Local Tuya)

Hi all,

I bought a Beok Glass TGW60B-WIFI-WPB Thermostat (this https://es.aliexpress.com/item/1005004395251051.html) to replace my old Beok 313 WiFi one, and I am having some troubles at the time of integrating it to HA.

When Using Local Tuya, I get the following IDs and values (I put a brief explanation after the ones I know):

1: true (device ID)
2: 215 (target temperature)
3: 212 (actual temperature)
4: cold
5: 0
8: false
13: false
16: 0
20: -10
21: 60
25: 1
26: false
31: false
41: 1
42: 1
101: false
105: 10
107: 35

The Thermostat is showing up in HA, but its state is always “Auto”, even if it is Manual mode and there is no way I can modify its state, it is just automatic.
I also tried to retrieve the ID states when the thermostat is heating and when it is not, and the states apart form the temperature itself are not changing at all (checked this for a while and the temperature ones were changing, so it was actualy refreshing itself).

Do you happen to know what I am doing wrong?

Thank you!

Nobody with the same issue?

For Beok TGW60W-WIFI-EP
LocalTuya integration, fill out the details for an entity with type climate


Get - lovelace

Achieved to switch modes! I had to add lines in the climate.py file





/config/custom_components/localtuya/climate.py

HVAC_MODE_SETS = {
    "manual/auto": {
        HVAC_MODE_HEAT: "manual",
        HVAC_MODE_AUTO: "auto",
    },
    "Manual/Auto": {
        HVAC_MODE_HEAT: "Manual",
        HVAC_MODE_AUTO: "Auto",
    },
    "Manual/Program": {
        HVAC_MODE_HEAT: "Manual",
        HVAC_MODE_AUTO: "Program",
    },
    "m/p": {
        HVAC_MODE_HEAT: "m",
        HVAC_MODE_AUTO: "p",
    },
    "True/False": {
        HVAC_MODE_HEAT: True,
    },
    "1/0": {
        HVAC_MODE_HEAT: "1",
        HVAC_MODE_AUTO: "0",
    },
    "hot/cold": {
        HVAC_MODE_HEAT: "cold",
        HVAC_MODE_AUTO: "hot",
    },
}
HVAC_ACTION_SETS = {
    "True/False": {
        CURRENT_HVAC_HEAT: True,
        CURRENT_HVAC_IDLE: False,
    },
    "open/close": {
        CURRENT_HVAC_HEAT: "open",
        CURRENT_HVAC_IDLE: "close",
    },
    "heating/no_heating": {
        CURRENT_HVAC_HEAT: "heating",
        CURRENT_HVAC_IDLE: "no_heating",
    },
    "Heat/Warming": {
        CURRENT_HVAC_HEAT: "Heat",
        CURRENT_HVAC_IDLE: "Warming",
    },
    "1/0": {
        CURRENT_HVAC_HEAT: "1",
        CURRENT_HVAC_IDLE: "0",
    },
}

Hi iliya555,
Thak you so much for this!

I tried your settings and it is now working fine, thank you :slight_smile:

I had to modify the teperature step to 0.5, otherwise the device was not even showing up.

But for the rest, everything is now working fine.

Thanks again :slight_smile:

HI worked for me fine for TGN50 and TGM 60 Wifi models.

One Question which automation do you use to control the thermostates? Because mine are switching from manual to programable randomly so a correct automation can not be realized. Probably someone can help me for that.
Greetings
Martin