Best dishwasher for Home Assistant

After living with the Bosch for a couple of months, I can’t recommend it. Three times the connection has been lost and three times I’ve had to wipe it from the app and start again. Now this latest time, when trying to register it AGAIN, the app is getting error H9208 - Connection with the server has been lost. Naturally this error code exists nowhere on their website. And yes, I run all my iOT devices on a separate 2.4GHz guest network. I’m hoping their servers are temporarily down.

24 days ago you said, one week ago.
So that’s one month.
That isn’t really my point but if it is one month and you had three connection failures then that is really bad.

I don’t think our washing machine has dropped off from the Bosh connection ever. Haven’t paid enough attention to it.
But the integration has issues, or probably the API.
But that’s a different matter I guess.

I have dumb washing machine and dumb dishwasher. But they can be integrated into home assistant with some contact sensors and smart plugs. Check this post.
Every setup is a bit different but generally this can be done using instructions in above post.

There is a big difference between a smart appliance and an appliance with a contact sensor on it.
I wouldn’t say my front door is integrated in Home Assistant because there is a contact sensor on it.

On the other hand the smart in them isn’t as smart as it could be, but I would still not say it’s the same thing.

1 Like

Well we have different opinions on it. It will be pointless discussion but I want just say, that from my point of view this setup suit my needs. I automated my washing machine and my dishwasher to strat washing when electricity is cheaper, I can get status of it and notification when they are finished on my alexa and my mobile using telegram integration. It’s smart enough for me.

Haha, that’s picky. I have to confess I didn’t check the purchase date, but it felt like I’d had it more than a month but not more than two. And yes, three reconnections in a month (or two) is rubbish.

And I should add the dishwasher thinks it’s on wifi (it’s lit up and not blinking), but it’s nowhere in pihole. Time for a factory reset methinks.

What does the app say, do you have local control of it?

No - for a while the app was flickering trying to connect but never could. Which is why I removed it from the app and tried to start again. So it was no longer in the app, and couldn’t be added.

I’ve just done a factory reset on the dishwasher, and now I’ve been able to add it back. A reload of the integration meant that’s working again too. I hope it’s the last time.

…and neither HA nor the app can connect to the dishwasher again. HA thinks it is connected, but turning it on/off does not work. And the app doesn’t even try to connect. One final thing I’m going trying before a warranty call is a connection to a non-mesh wifi network, as I had another device that didn’t seem to enjoy mesh.

I’ve always used mine with a mesh network… I had some disconnections, I’m not go a say this never happened, specially because I’ve mentioned about those disconnections on my first message in this thread, but usually I have it working fine for months before it gets disconnected, then it happens a couple of times in a short period, then I have a few months with everything working fine again…
But again, my one works fine with the mesh network. I used a Tenda Nova MW6 before, but since a couple of months ago I’ve migrated to an ASUS XT8 with no issues since then…
So, I don’t think the mesh is the problem.

Way to ruin my last hope :rofl:. Well it’s on a separate wifi network now that only has two other devices, whereas my normal 2.4GHz network probably has well over 64 devices, so I’ll see how it goes.

Sorry for that…

So how dod it go?

I try to connect my dishwasher, but also face the H9208 when trying to connect.
The first time happened after entering wifi info, the second one even without asking for wifi.

I seem to be stuck at connecting it to any network :frowning:

Badly. Independent of HA, the Home Connect app often can’t connect to the dishwasher, despite the fact that the dishwasher thinks it’s connected to wifi. So in my case it’s probably unrelated to the HA integration. I’ve been mailing the support contact, but they have been less than helpful. I gave up.

Hello, everyone,

I’m installing a new Bosch dishwasher (series 6), and when steaming in the app, error H9208 pops up at the end, have you found any solutions?

I can see it as online in the unifi network, everything is running on a separate ssid at 2.4 Ghz.