Best method to install HA into old PC?

I used to use HA in Windows Virtualbox. Now I have a dedicated PC for HA, but difficulties to get it running.

I tried to this: Generic x86-64 - Home Assistant and flashed USB stick with Balenaetcher but my PC wont do anything with it. Tried to flash PC’s hard drive with the same way, but it wont boot.

Now I have Ubuntu server installed and thought to install Supervised but some says this is not necessarily the best way to install HA. GitHub - home-assistant/supervised-installer: Installer for a generic Linux system

Is the only option to run HAOS in virtualmachine? I would run also Frigate with few cameras so the installation should be as efficient as possible and I’m thinking if OS running in OS isn’t so efficient…

My PC is HP Elitebook 8540w.

Hi, have you seen this? Installation - Home Assistant

As you can see from my signature, I’m using a bare metal hypervisor so I can maximize the use of that system and run different stuff aside of HA

Thanks Nick. Yep, I have seen that link. I will google more about that bare metal hypervisor.

There are guides here in the forum for Proxmox VE.
It all depends on what you want to achieve and the kind of hardware you want to use.

There are different solutions for virtualization and it has a learning curve but it gives you flexibility and to centralize multiple services on 1 pc where one will not affect the other.

The image is not bootable from USB.

You load a linux “live” bootable image onto the USB stick, boot the PC with that then install the image onto the system drive with balena etcher and the image url.

The other option is to remove the system drive from the HA PC connect it to another PC (internally or with an external enclosure), burn the image directly to the drive then install it back in the HA PC.

This is all detailed in the installation instructions:


and to give you another option, this works for me


I use an old pc as a backup system and for testing stuff. I just take the hard drive out and connect via a usb adapter to my daily PC and flesh it from there, plug the drive back in and away it goes

1 Like

I tried that. Removed the HDD from HA PC and connected it via USB adapter to another PC and flashed with Balenaetcher. But the HA PC didnt boot. I will try again, I did something wrong. Thank you.

does your pc meet the pre-requisites?

Otherwise yes but not sure if uefi works correctly. It warns in bios that uefi is experimental. Its over 10 years old. Have to check if bios update helps.

UEFI works with Windows installations from USB stick but with system HDD flashed with the haos_generic-x86-64-7.5.img it says this: (image)Näyttökuva 2022-03-24 212925

install debian and then a supervised docker install

Supervised should be the last resort. Better to use Container or of you want the simplicity of addons and cant use the bare metal HA OS option then use a VM/VE of some description to run HA OS.

1 Like

As mentioned above Container is an interesting option. Note it is not the recommended method of running home assistant as it has some drawbacks (it all boils down to how comfortable do you feel using the command line), but I run home assistant and many other supplementary services on my pi4 in docker with no issues. If you go this route I’d recommend using docker-compose as it makes life much easier.

Why should it be a last resort?
I really don’t get it why it is being discouraged.
Atm, I am setting up a debian installation, and i use supervisor, as i like it…
It runs fine and gives me the flexibility i want…

1 Like

The devs hate it. It was going to be unsupported. It was only reluctantly allowed after a public outcry.

It has some strict conditions. It is easy to fall afoul of these conditions and people wonder why they can’t update Home Assistant when the system is tagged as “Unhealthy”.

It can be difficult to identify that the underlying dependencies need updating. Especially if the release notes for new versions of Home Assistant are not read.

Thanks for the explanation, ofc devs need to keep in mind that there are many users to do not have the required skills, i tend to forget that :wink:

1 Like

Bought newer PC. Flashed HDD. It works now :slight_smile:

Meanwhile, people are also running afowl of other more prefered ways, go figure.

It is fortunate that they are supported then.