Best way of integrating existing Miboxer LED strips with Home Assistant

Currently I have a lighting setup across a couple of rooms that is a mix of Philips Hue lighting, and Miboxer LED strips. The controllers on these LED strips I noticed are listed at RF 2.4 (when I bought these a few years ago I wasn’t on board the home automation trian yet), which is a bit unfortunate.

Does anyone have any tips on how I could go best about integrating these LED strips with Home Assistant? Buying new controllers would be okay too, I’m honestly unsure which path to take with this.

Is your existing miboxer zigbee?

LimitlessLED - Home Assistant works fine with it :wink:

Unfortunately the two controllers (one per LED strip) just have the 2.4 RF logo on them, same for the remote. So I’d have to look into if they have the same RGBW controllers but then with Zigbee.

You need this one 2,4GHz Gateway - Milight Nederland it will work :wink:
MiLight use it’s own protocol over 2.4GHz.

Alternative in the DIY world also exists: GitHub - sidoh/esp8266_milight_hub: Replacement for a Milight/LimitlessLED hub hosted on an ESP8266

That one would become very handy, if you have to control a lot of lamps or strips.

Or, like you said, you can use different strip controllers…

2 Likes

I’ll opt for the DIY solution, I already have a ESP8266 laying around. Thank you for the pointers!

1 Like

Hi @BebeMischa, do you have one working?
I’m trying to do so but nothing happens in HA.

configuration.yaml file:

light:
  - platform: limitlessled
    bridges:
      - host: 192.168.1.52
        groups:
        - number: 1
          name: LEDstrip

IP is correct, the device does work with the mobile app (miboxer)
After multiple scans without any result I found port 6668 as open (cannot connect with browser)

Where can I find the version of the device?

Is this the IP of the light device itself, or the IP of the WiFi bridge (hub)?

Hi, it’s a ledstrip with a miboxer ?bridge? (the 2,4GHz Gateway you linked to above) so it’s the IP of that miboxer gateway.

light:
  - platform: limitlessled
    bridges:
      - host: 192.168.1.52
        groups:
        - number: 1
          type: rgbww
          name: LEDstrip
          fade: true

try this, don’t forget to restart HA to make changes happen.

Nope, basically it’s just the ‘fade: true’ that differs from what I tried and it seems that this is not a required option.
Do you now what the importance of the correct group number is?
In the app there is only this device so I used 1.
Of course I restarted HA every time I changed the settings.

Any idea about how to find the version number of the device, maybe that is the problem.

actually the more important change was the TYPE. That is required.

There was a topic around here about the versions, try to find it… :wink:

I never paid too much attention to it, as for me it works fine without specifying versions. I have three of the hubs and all work fine without.

My working code:

# MiLight integration
light:
  - platform: limitlessled
    bridges:
      - host: 192.168.188.32
        groups:
          - number: 1
            name: Keuken tafel
            type: rgbww
            fade: true
          - number: 2
            name: Slaapkamer lampje
            type: rgbww
            fade: true
          - number: 3
            name: Slaapkamer paneel
            type: rgbww
            fade: true
          - number: 4
            name: Terras lampen
            type: rgbww
            fade: true
      - host: 192.168.188.39
        groups:
          - number: 1
            name: Woonkamer lamp
            type: rgbww
            fade: true
          - number: 2
            name: Keuken werkblad
            type: rgbww
            fade: true
          - number: 3
            name: Simcave lampen
            type: rgbww
            fade: true
          - number: 4
            name: RaafLedStrip
            type: rgbww
            fade: true
      - host: 192.168.188.41
        groups:
          - number: 1
            name: RaafLamp
            type: rgbww
            fade: true
          - number: 2
            name: Badkamer lamp
            type: rgbww
            fade: true

1 Like

The gateway doesn’t mention anything regarding color mode but the controller is a FUT045 (RGB+CCT)

try rgbww or rgbw.

Then there is also the possibility, that you need to specify version, something like this:

 platform: limitlessled
  bridges:
    - host: 192.168.0.258
      version: 6
      port: 8899
      groups:
      - number: 1
        type: rgbww
        name: Master Bedroom

I just don’t know exactly all the ins en outs, you have to google that.

If both do not work, you will need to switch over to the DIY hub.

Or just forget about it :slight_smile:

Just adding an alternative solution as I stumbled upon this thread: it appears that Milight/Miboxer now also offers LED drivers with Zigbee support.

For example, I currently have an FUT035S+, which I’m about to replace with an FUT035Z (e.g. see here), with the Z indicating Zigbee support.

This should allow the LED strip to be added to Philips Hue or IKEA Tradfri, in case you’re already in those ecosystems, which in my case is a great route to get Home Assistant to work with it.

Depending on the number of LED strips you’ll want to make available in Home Assistant, buying their Bridge might be cheaper, although that bridge apparently likes phoning home, which the LED driver with Zigbee won’t/can’t do.

I’ll report back once I had a chance to try the new Zigbee LED driver.

Just installed both LED drivers and they seem to work like a charm! They were a drop in replacement for the original drivers, and after pressing the SET button three times to enable Zigbee discovery, the Hue app found them quickly, with both brightness and color temperature control!