Best way to have Configurator autostart in Hassbian?

I just recently switched from to Hassbian. Most of everything worked right away once I copied over the config directory. Two main things that I am having to setup manually is appdaemon and configurator. I have appdaemon setup and working as well as set to autostart.

I currently have Configurator working, just need to have it autostart when Home Assistant reboots. Looking at the documentation, it has me edit:

/etc/systemd/system/[email protected]

with the following:


#Set the path to your location
ExecStart=/usr/bin/python3 /etc/homeassistant/ settings.conf


However, I have already done something similar with appdaemon. So that service already has that template in it for appdaemon. My question is, can I add the Configurator template below what I already have for appdaemon or will there be a conflict with the headers? Or is there a better way of going about this? I feel I’m overthinking it.

1 Like

You need a separate .service file for each service you start. So put that code in a file called /etc/systemd/system/configurator.service then

$ sudo systemctl daemon-reload
$ sudo systemctl start configurator.service
$ sudo systemctl enable configurator.service

You should also have separate service files for appdaemon and homeassistant, and from your post I’m not sure that is the case.

1 Like

It is not, I will get that fixed.

Edit: I stand corrected appdaemon is its own service.

Dear gpbenton,
Same question as makani47.
I do not how to create a new file as per your suggestion. Can you tell me how?
Thank you in advance
Minh Chau

Dear makani47,
How can you do it?
Thank you
Minh Chau

After all, got it work


Did you guys get to the bottom of this? Can anyone help me get the configurator working?

I have got as far as executing the sudo ./ command which gives the following

INFO:2019-07-09 11:46:06,200:main:Starting server
INFO:2019-07-09 11:46:06,201:main:Listening on:

What do I do next? Does this mean the configurator has started?

I have also added information for the iframe in the configuration file, however am not sure which url to enter?

Hope this makes sense and thanks