Better Blueprint to report when any battery device (Zigbee/Zwave etc) or Zigbee/Zwave SmartSwtich has gone offline

for me it doesn’t work either - I am getting following warning - WARNING (MainThread) [homeassistant.helpers.template] Template variable warning: ‘offline_devices’ is undefined when rendering ‘Folgende Geräte sind offline: {{offline_devices}}’

So a notification was sent to the HA app but just the text “Folgende Geräte sind offline:” - nothing else. Any advice what I am doing wrong ?

It “works” for me, except that the unavailable device it lists is just the generic manufacture name and not the friendly name. So among my dozen motion sensors, for example, I don’t know WHICH one is dead. Not too helpful.

hi, just checking back in to see if you had time to work on an update?

thank you!

Hi, just forked it to have friendly_name.
You can just use [state_attr(sensor.entity_id, “friendly_name”)] %} (line 49) to get it

You can import the fork to your HA instance using this url: Home Assistant Blueprint: Low battery level detection & notification for all battery sensors · GitHub

My report always shows my “Hue Bridge” is offline which it isn’t. The “Hue Bridge” is a device only without a similar entity. Hue Bridge is NOT even a battery device.
Excluding it (Device) doesn’t work either although I’m not sure what your device disclaimer means.

I’m alerted with “Roborock S7” on every run, even though i’ve excluded the “sensor.roborock_s7_battery” entity. is this fixable?

1 Like

@corgan By any chance have you found any workarounds to this?

I too seem to be running into this same issue with my Echos, and if there might not be a workaround, I might have to disable this blueprint (since otherwise I’d end up getting a report with 8 false positives every day).

I resolved my “Hue Bridge” occurrence as an “unavailable” battery device appearing in my offline list. The culprit was a Hue light bulb automation and/or switch with a state of “unavailable”. Don’t know what it is or where it came from, but either setting the state to off or excluding the entity (not named Hue Bridge, but named Desk Lamp On (automation) resolved it.

Go through the Entity exclusion list in the automation and exclude everything then turn them off one at a time to find the issue. It will likely have a different name than the false positive.

Thanks for your Blueprint (BBBAAA, Modular Taco). I love it.

same here. how can I find the “wrong” sensor?

First of all, thanks a lot Tahutipai for your blueprint. I was looking for this for some months.
I started to install it and excluded some devices considered non relevant and reported when the automation was executed. Worked well using entities instead of devices.
Will see in due time


Well, after some days, I can’t make it work. I scheduled if at 10 everyday, but the automation is not playing.
I also have deliberately put a zigbee sensor offline. When I manually execute the automation, it does not appear in the list.
I don’t know what could possibly be wrong. Any help or clue would be much appreciated.