Better Thermostat with Shelly TRV

Hi, I am quite frustrated with my Shelly Trv’s as they keep ignoring the external temperature sensor. so I wanted to do it all via HA.

Yesterday, I set up the “Better Thermostat”.
Initially (manually) it worked nice, however, as soon as I send via the the better_thermostat.set_temp_target_temperature, it turns to eco mode and does nothing anymore.

I read now the documentation multiple times but I am not sure what I am missing.

What is the point of setting a temperature if it isn’t actually trying to match it?