BLE Beacon - issues with Pixel 3

Has anyone tried the new BLE Beacon option? It doesn’t advertise at all on my Pixel 3. Tried everything - ESPHome BLE tracker - nothing. ESP32-MQTT-ROOM - nothing.

Is there some other setting on my Pixel I need to mess about with?

I thought this would be a great addition to the app and was really excited. A pity it seemingly does nothing on my phone (typical for me!!!)

Double check that the sensor is transmitting when enabled and that you have setup esphome properly to detect it by the ID in settings.

Probably follow this one: https://esphome.io/components/esp32_ble_tracker.html#on-ble-service-data-advertise

I’ve tried toggling everything. Using ESP32-mqqt-room I simply see this in the serial log.

image

It’s like there’s nothing transmitting at all (I assume it would pick a beacon). I have matched the UUID’s and there’s nothing in the MQTT traffic apart from the fact the sensor is alive.

so you followed this? https://jptrsn.github.io/ESP32-mqtt-room/beacons

Did you check any other troubleshooting step with this? Have you opened an issue? The transmitting does indeed work so the issue may be with the setup or the product you are using. Room Assistant for example does work.

Edit: might be of help too: https://github.com/jptrsn/ESP32-mqtt-room/issues/43

Always do as much research as you can into github issues and everything

Thanks - I’ll check that out!

You are a star! Thank you so much for assistance :slight_smile: It’s now scanning but it’s still not picking up the BLE Transmitter in the app. Same as ESPHome. I’ll raise an issue in case there’s something odd about the Pixel 3.

1 Like

I can tell you that my Pixel 3 XL seems to work. I’ve been testing it with Room Assistant.

Sussed it - it doesn’t matter what you put in the UUID. It remembers the initial entry the app gave it. Even re-installing doesn’t take the UUID it shows in the app. I am now tracking my phone but it’s using the UUID it had yesterday - I have confirmed this by turning off the transmitter and watching the reports from the beacon stop.

does the attribute of the sensor update when you update the sensor setting?

Yes - the attribute changes. However the phone is broadcasting the original it was given when I installed the update yesterday. I’ve got 4 sensors around the house and they are all following the phone via it’s old UUID. Most curious!!

What version of the app are you on?

beta-637-94e1f15-full

Can you open an issue on GitHub and provide all this information so we can look into it

Hi, I’m trying to use the BLE feature in the HA app but my esp32 doesn’t see my phone even i have enabled the BLE ibeacon feature. Am i missing something?