Ble entity stays Not_home all the time

trying to use esp as room presence
added these lines to sensors.yaml and my Entity is ‘not_home’ all the time:

- platform: mqtt_room
  name: "my_ble"
  device_id: "iBeacon:cc908710-e776-4cc5-98e9-xxxxxxxxxx-xx-x"
  state_topic: "espresence/rooms"
  timeout: 5
  away_timeout: 120

I got the ID from the esp terminal

any idea

There is something strange with the UUID. It should look something like this:


the -xx-x thing on the end of yours is probably the major and minor, but I am not sure if your integration requires those or not. You should double check that first. Maybe you only need the UUID and don’t need to tack on the major and minor.

In addition, there is definitely something wrong with your UUID. The 5th chunk of numbers/letters should be 12 characters long. For example, my UUID’s 5th chunk is 6561636F6E73. But your 5th chunk is too short; only 10 characters long: xxxxxxxxxx. Maybe you made a typo trying to hide your UUID or maybe you are using the wrong UUID and/or forgot some characters?

(FYI, UUID’s are not confidential. Feel free to post them wherever. They are publicly broadcast by your iBeacon as well. If you want to be really careful, you can also change one or two of the characters later.)

You also might want to post your ESPresence settings screenshots here so we can give you some suggestions for what to adjust.

found the problem:
this should be the lines in Yaml

state_topic: 'espresense/devices/iTrack:xxxxxxxxxxxx'

and not as I have written above