BLE Not Working at HassIO 105.3 and HassOS 3.10

Hi

I was previously using HassIO 104 with HassOS 2.x and BLE worked great with MiFlora devices. However since upgrading the Host system and the HassIO version my MiFlora devices dont work anymore.
No errors in the logs that i can see and my sensor configuration is good against the current documentation.

Is anyone else experiencing BLE issues with the current HassIO and HassOS 3.10?

I’d be grateful if anyone has any tips or whether this is a bug in HassOS 3.10 as i read some comments from others about BLE presence detection not working >HassOS2.12 so i fear its a BLE bug in HassOS…

Cheers
Craig

I’m currently on HassOS 3.9 and Home Assistant 0.105.3 and am not able to access MiFlora data. Occcasionally I get the battery level only, which is strange.

Hi Max

I was able to get MiFlora working again once I reverted back to HassOS 2.12. Seems any version after this cannot connect to ble devices.

Craig

also having issue using miflora

rpi 3b+ hassio
version 200 - hassio 3.10 - Home Assistant 0.105.3

To roll back to HassOS 2.12 i used this command successfully using the command prompt in an SSH connection to the RaspberyPI 3+:

“hassio os update --version 2.12”

Miflora sensors will work with a Pi 4 (at least) with the latest versions of HA, by using the alternative component:

This can be installed with Hacs, and works much better than the standard component:

  • Batteries will last longer, as no direct polling is required.
  • The white round Xiaomi Temp & Humidity sensors will return values less than 10 c which the built-in component has problems with.

I recommend trying out the above component with your set-ups before giving up :slight_smile: