Blind - incorrect "state" & not behaving properly

My cover.utility_room_blind (Zemismart motor / SmartLife iOS app / Tuya integration) is showing conflicting info, and I am not sure how to resolve it.

With the blind physically OPEN, Developer Tools reports ‘open’, but if I click on the info icon it shows it as closed (see screen grab below).

Within the Smart Life iOS app the position, state & controls are always correct.

If I close the blind using the SmartLife iOS app, and then tap on the Lovelace button, the blind opens BUT I then can’t close it through Lovelace (the blind moves very slightly - so “a” message is getting through - but it is not jammed). It is as if the state is not updating somehow.

I have tried deleting the Lovelace button & recreating it, and have also re-started HA many times.

Any ideas?


1 Like

I’m having basically the same problem: the controls for my blinds seem to be reversed. There are trhee control buttons: an up arrow, a square (stop) and a down arrow. But when the blinds are all the way up (in RL) the down arrow is greyed out and only the up arrow is available, and vice versa. And if the blinds are somewhere halfway closed, usually one or the other of the up/down arrow control buttons are disabled.

Did you ever figure out a solution? Does anyone have any insight into how this can possibly be corrected?

FWIW, I’m using the HubZ Smart Home Controller integration, and the blinds are by Yooksmart (Yoolaw brand blinds purchased from Amazon).


@judetf - I am afraid that I never did find a solution. But if you do, please do share it!