Blind state and Zigbee2MQTT

I have a problem with a Blind I just added - the state doesnt seem to align (at all) with Zigbee2MQTT and home assistant

Essentially Home Assistant shows the device as closed all the time (irrespective of the flip state option in the Fyurtur settings)

So what I get is the following:


This means that I cannot take any actions to close the blind since it’s greyed out, even though it’s fully open…

Any ideas how to fix?

Have you set the end point?

Have you tried re-pairing?

Set the end point on the blind itself? Yes
Re-pairing, yeah I tried that as well

Even if I close it and then open it halfway, the down arrow still stays greyed…

Just to add, the controls on the Zigbee2MQTT page work perfectly:
(these ones)

It’s just the ones exposed to Home Assistant which don’t seem to align
I can seem to get them to change, (I just opened via the Zigbee2MQTT dashboard and this forced the Home Assistant dash to understand that it had moved), but then closing via the home assistant dash partway, it didn’t release the up direction…

Edit2: Seems that setting a position that is not 0 or 100 in HA will give both arrows, but hitting down (or up) sets that value to 0 or 100 irrespective of when the blind is stopped…