Blink camera - preview not showing


Trying Home Assistant for the first time on a Raspberry pi 4 - all installed and working fine.

Added Blink camera integration and camera info appears in my dashboard, but when clicking on a camera the preview image is not showing - just an icon as per image below


What have I done wrong? or how can I get it working correctly please


I’m having the same issue here, integration linked correctly with my account, but I am unable to generate a preview on my dashboard. I will keep trying, and researching and let you know what I find.

I just got my pair of Blink XT2’s recently and haven’t really messed with the app settings, but went through each cam’s settings and went under the “Activity Zones” section and I was immediately prompted to “Update Photo” in the app, then I refreshed my Home Assistant instance and boom! My images from my cams are coming through now!

Were you able to get this working @wingers ?


No I never got it working so gave up, but if I try it again I will see if doing the same works for me - thanks

1 Like

This worked for me! Thanks a lot! :slight_smile:

1 Like

this worked! I set the zone in the blink app, then I went to the blink integration settings in home assistant and selected ‘reload’.

1 Like

Works great, thanks

1 Like