Blink Save Video - 'Can't write image to file: Invalid URL 'None': '

I’m trying to save video from one of my Blink cameras. However, when I try to run the automation this error is in the log, and it doesn’t seem to relate to any options in the documentation.

Can't write image to file: Invalid URL 'None': No schema supplied. Perhaps you meant http://None?

Here is the yaml for my automation:

alias: Blink Video
description: ''
  - platform: state
    entity_id: binary_sensor.blink_front_door_motion_detected
    to: 'on'
condition: []
  - service: blink.save_video
      name: Front Door
      filename: /tmp/blink.mp4
mode: single

(Why i’m writing the file to tmp is for another help topic but just saving there for now would be a start).

Any ideas?

1 Like

I am having the same problem. Did you ever figure it out?

Nope! I’ve given up. One thing I have thought though is that the documentation refers to the name of the blink sync module 2 - which doesn’t seem to be referenced in the example config itself.

I’ve got the free trial of cloud storage of video clips - i’m wondering if it only works when you’re saving locally to the sync module? When my trial runs out i’ll try again then. Just a total guess though.

Any luck? Same issue…

1 Like

I’m having the same issue as well with the Sync Module 2

Anyone resolve this issue? I’m having the same problem.

Interestingly, the “No schema” error only shows up with some cameras… while with others the video save service works as expected.

Any pattern to that? Are the cameras all the same model, or different?

My cameras are a mix of XT2’s and the new “Outdoor” model. But I don’t see any correlation.

I did notice a pattern, maybe. If I restart Home Assistant and then try Blink Save Video service right away it doesn’t work. I get the “Can’t write image to file: Invalid URL ‘None’: No schema supplied.” error.

But if I walk in front of the camera and trigger the motion detection, then the Blink Save Video service works and it can pull the last recording. Now the save video service is working on most of my cameras after having forced a motion event (still getting an error on two cameras, not sure why). But this issue pops up again after every restart.

My other issue is with the automation trigger. Using a state trigger on motion_detected to ON doesn’t work for me. I’ve resorted to downloading the last recording every 2 minutes and then auto deleting duplicates.

Yes I think the motion events can’t be trusted because it polls the service to see if motion occurred. It can easily miss a motion event if it happens between polling times.

It seems that setting up an IFTTT webhook is very reliable for motion events, since Blink service seems to push to IFTTT paid account right away when motion is detected.

That said, I still can’t save any video.

I have done some investigation on this since it seems I have the same issue.

My automation is just a copy of what @pjn77 is having, and actually a copy of what is written in the documentation.

What I found is that the automation does not fail and actually saves the video on the filesystem if the video is already present in the blink automation.

I guess that since a motion detection is triggered we have to wait for the video to be available online or or on the Sync 2 Module we have to wait for the recording to be finished before saving the video itself.

The length of the pause should be a little bit longer than the recoding time set in the Blink application on the mobile phone plus some more time to let the remote system to finish writing the file.

Unfortunately I did not have time to check if this was the case. i will make some more tests in the next few days.

Hope this helps.

Hi all,
I am trying to setup my blink environment on HA and I have exactly the same problem.
Trying directly from service call:

service: blink.save_video
  name: pasillo2
  filename: /share/videos/pasillo2.mp4

I get the same error about “invalid URL”

But if I try to get a snapshot with:

service: camera.snapshot
  filename: /share/videos/pasillo2.jpg
  entity_id: camera.blink_pasillo2

It works perfect… I will keep you updated if I found something relevant

Anyone have an update on this? Getting the same error.


same error :frowning:

@fronzbot Have you seen this thread? I was trying this with the dev branch now that the video doorbells are included and found that the video attribute on all of my cameras was video: null. Wondering if that has something to do with it when using the sync module 2?

CC @magicalyak since you did the heavy lifting for the most recent version of blinkpy.

Hello all,

After a bunch of trial and error, I finally was able to get a blink camera video to share. However, I’ve encountered this issue when I copied my working automation for one camera and then edited for another camera. So I have 1 camera that the automation and saving the video file works while the other camera doesn’t and I get the same error.

“2021-12-28 10:23:37 ERROR (MainThread) [homeassistant.components.blink] Can’t write image to file: Invalid URL ‘None’: No schema supplied. Perhaps you meant http://None?”

I have 6 cameras around my house, 3 XT2s, 2 of the newer style XT2s, and 2 Blink Minis. And I have a door bell camera as well.

The one that is working is the newer style XT2 with the 10.50 firmware and the one not working is the older style XT2 with 7.101 firmware. I have not tested a mini yet. All of these are running on the older sync as I never activated the newer sync. My sync module is running 4.4.3.

If you need me to run another test on these let me know. With it being a week between holidays work is light and I’m working on home projects while I keep my self available for work. :slight_smile:

Is there a common thread here someone can point out? I’m happy to take a crack at it but I don’t think I have this issue myself. For example, is this related to the sync module, certain cameras? Is it the older XT2s (can those not be upgraded or is the firmware upgrade (new) the common link to the problem)?

Ok with further testing I’ve been able to get all my XT2 cameras to work. Both new and old. The only devices that don’t seem to work at this point at the Minis and the Door Bell cameras. But the door bell isn’t picked up at all at this point so I’m less inclined to think we can tackle that one.

As for the minis has anyone been able to get mini videos to save?

FYI, now all my cameras work. Both versions of XT2s, Minis, and the Door Bell. The only thing I can’t figure out so far is how to capture a video if someone presses the door bell button and it records as it appears that is separate from “motion”.

Can you share what you have done to make it work (scripts/automation)? You’re the only that seems to have managed it.