BlitzWolf BW-SHP13 not showing power consumption

It works with Zigbee2MQTT


Im not an expert at all, but I think that the temperature sensor can have multiple entities because each one has its own zigbee cluster: Humidity / Pressure / Temperature / Power.

However on the smartplug, both energy consumption (kWh) and power (W) share the same zigbee cluster: ElectricalMeasurement.

My understanding is that right now ZHA only allows one entity on each cluster. You could also try with Zigbee2MQTT to see if that works better in this case.

I am also with ZHA and can confirm the same. Is it possible for the ZHA integration to add this capability in the near future? Or is it a limitation by design?

hello, any update about this issue in ZHA?

I tried to show power consumption using the template integration:

  - platform: integration
    source: sensor.blitzwolf5_tv_power
    name: blitzwolf5_energy
    unit_prefix: k
    round: 2

but it show me the following error:

2021-02-13 11:43:33 ERROR (MainThread) [homeassistant.components.sensor] Error adding entities for domain sensor with platform integration
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 315, in async_add_entities
await asyncio.gather(*tasks)
File “/usr/src/homeassistant/homeassistant/helpers/”, line 506, in _async_add_entity
await entity.add_to_platform_finish()
File “/usr/src/homeassistant/homeassistant/helpers/”, line 530, in add_to_platform_finish
await self.async_added_to_hass()
File “/usr/src/homeassistant/homeassistant/components/integration/”, line 125, in async_added_to_hass
self._state = Decimal(state.state)
decimal.InvalidOperation: [<class ‘decimal.ConversionSyntax’>]

I havent got this working yet no. But i am using Conbee/Decons, not zha.

No, wait and see if ZHA devs comment more in

ok great, I’ll take a look also to the issue you posted, thanks!

I’m using phoscon/deconz and have the same problem. I had a bunch of this sockets working fine but this specific one only shows Switch on/off.

Same issue here. Latest version of deconz and HA. I deleted the device via the deconz REST API and tried to pair again, but it keeps coming back with only on/off. Very strange because it’s identical to another SHP13 I have that works fine (power & consumption sensors are created). In deconz, both have correct real time metering values.

1 Like

Everyone with this problem might want to check this thread (it solved my issue):

I fixed 2 of this devices only with switch doing the following:
(Device previously added and online as a light, with some item connected to the socket/plug turned on)

In deconz:

  • Panels, Cluster Info, Basic
  • Reset Factory reset (Exec button)
  • Go to Phoscon, Add SENSOR (not light)
    And it turns green as a discovered sensor.

is there also fix for this issue while using ZHA ?

same here, actually I am happy using ZHA instead of phoscon so I prefer waiting for a solution in ZHA.

Still waiting? The corresponding GitHub issue is still open…

Everyone should report YOUR issue to it →

Developers might not be looking at issues which have to activity and no more users posting debug logs.

Are there any news yet?
I have 3 SHP15 and the power consumption in kilowatt hours worked like a charm with Sonoff Dongle-E and ZHA. Now, I was thinking to buy some of the SHP13 as the SHP15 is not available at the moment. I really want to have to power consumption.
Is the problem solved in the newer versions of ZHA?

This is how my SHP15 looks like in Home Assistant.

is it possible to update firmware on TS0121 BLITZWOLF® BW-SHP13

in deconz


Most Chinese device manufacturers don’t provide Zigbee OTA firmware image updates for their devices:

1 Like

FYI, victorigualada wrote a step-by-step guide in the Home Assistant community forum on all the elaborated steps currently needed for an end-user to manually apply a custom Zigbee OTA firmware image to a device in the ZHA integration if there is not an OTA provider in zigpy: