BlitzWolf BW-SHP13 not showing power consumption

Newbie alert


Somewhat new to HA, so bare with me - might be a simple fix :slight_smile:

i bought a set of BlitzWolf® BW-SHP13 Zigbee plugs, connected via Conbee II.

The devices should be able to view power consumptions ect, but in HA i only get on/off entiti. Anyone else using these and know what to do?

In Deconz, i can see the power consumptions by number.

Check the Blitzwolf Plug in the Deconz devices list on the Integration page (http://:8123/config/integrations) - for me the plug device contains a switch entity and 2 sensors - one for power and one for overall consumption

1 Like

It only shows one.

I bought two of them
One of them is precented as Vendor: “_TZ3000_g5xawfcq” Model: TS0121
The other one is precented as Haiman / TS0121

Does not seem to show any sensors.


Little “same” problem.
I’ve the same plug and with HA it’s show me 3 entity but overall consumption stay in unknown (I use for a week and no change).

The power entity work well!

I use ZHA integration module in HA.

Someone have an idea ? Thanks in advance :slight_smile:

2021-01-26 11_53_28-Window

I had the same problem, so a while ago I opened an Issue in zha-device-handlers github.

It looks like the problem is due to a limitation in ZHA: It’s only possible to create 1 sensor for each zigbee cluster.

Thanks for your answer … this limitation it’s only for plug like this one ?
Because I’ve other sensor like temperature sensor who show me multiple sensor like this one =>

2021-01-26 13_25_27-Window

It works with Zigbee2MQTT


Im not an expert at all, but I think that the temperature sensor can have multiple entities because each one has its own zigbee cluster: Humidity / Pressure / Temperature / Power.

However on the smartplug, both energy consumption (kWh) and power (W) share the same zigbee cluster: ElectricalMeasurement.

My understanding is that right now ZHA only allows one entity on each cluster. You could also try with Zigbee2MQTT to see if that works better in this case.

I am also with ZHA and can confirm the same. Is it possible for the ZHA integration to add this capability in the near future? Or is it a limitation by design?

hello, any update about this issue in ZHA?

I tried to show power consumption using the template integration:

  - platform: integration
    source: sensor.blitzwolf5_tv_power
    name: blitzwolf5_energy
    unit_prefix: k
    round: 2

but it show me the following error:

2021-02-13 11:43:33 ERROR (MainThread) [homeassistant.components.sensor] Error adding entities for domain sensor with platform integration
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 315, in async_add_entities
await asyncio.gather(*tasks)
File “/usr/src/homeassistant/homeassistant/helpers/”, line 506, in _async_add_entity
await entity.add_to_platform_finish()
File “/usr/src/homeassistant/homeassistant/helpers/”, line 530, in add_to_platform_finish
await self.async_added_to_hass()
File “/usr/src/homeassistant/homeassistant/components/integration/”, line 125, in async_added_to_hass
self._state = Decimal(state.state)
decimal.InvalidOperation: [<class ‘decimal.ConversionSyntax’>]

I havent got this working yet no. But i am using Conbee/Decons, not zha.

No, wait and see if ZHA devs comment more in [Device Support Request] BlitzWolf BW-SHP13 smart plug (aka Tuya TS0121) · Issue #605 · zigpy/zha-device-handlers · GitHub

ok great, I’ll take a look also to the issue you posted, thanks!

I’m using phoscon/deconz and have the same problem. I had a bunch of this sockets working fine but this specific one only shows Switch on/off.

Same issue here. Latest version of deconz and HA. I deleted the device via the deconz REST API and tried to pair again, but it keeps coming back with only on/off. Very strange because it’s identical to another SHP13 I have that works fine (power & consumption sensors are created). In deconz, both have correct real time metering values.

1 Like

Everyone with this problem might want to check this thread (it solved my issue):

I fixed 2 of this devices only with switch doing the following:
(Device previously added and online as a light, with some item connected to the socket/plug turned on)

In deconz:

  • Panels, Cluster Info, Basic
  • Reset Factory reset (Exec button)
  • Go to Phoscon, Add SENSOR (not light)
    And it turns green as a discovered sensor.

is there also fix for this issue while using ZHA ?

same here, actually I am happy using ZHA instead of phoscon so I prefer waiting for a solution in ZHA.