Blue/Grey Night theme

I updated this theme to be “Blue Night” and fixed some other things I didn’t like:

I didn’t like everything is grey anymore. You can easily change the “primary-color” yourself if you don’t like the blue or want the grey back.


Hi, this is my fgavorite frontend. One thing I miss is when my PIR sensor fires up the little man running is not highlighted in yellow (like defaultr theme) but stays in grey colour as when idle.

You know how to change this?

Remove the line “paper-item-icon-active-color: ‘var(–paper-item-icon-color)’”

I really like this theme and have HA switch to it automatically to it when it gets dark :+1:

I have only one issue. In Lovelace when using a gauge-card, the “red” color seems to be the same as the background color… So when the gauge turns red, it disappears:

this is my gauge config:

- name: Verbruik
    entity: sensor.power_consumption
    type: gauge
      yellow: 0.5
      red: 1.5
      green: 0
    max: 8
    min: 0

So when it gets above 1.5 the gauge disappears, yellow and green seem to be fine… (hope I’m clear what the issue is)

But can’t find what to change to correct this!

Pretty sure it’s because of this variable:

Change it with something you like

Since a few version the gauge has the theme option.
Create a theme in your themes.yaml

  label-badge-blue: "#55acee"
  label-badge-green: "#9bc53d"
  label-badge-yellow: "#fde74c"
  label-badge-red: "#c3423f"

and define it in the gauge config.

theme: th_gauge_3

So you can use every color for the gauges.


this is my favorite theme.
But in Logbook and History the date field is “hidden” because too dark.
How can i fix this problem?

Thank you.

1 Like

I think it cannot be changed… I can’t find a variable that changes this.

Below are the css attributes I modified to attempt resolving that with my dark theme. Some modifications I still need to make are lumo-shade (or lumo-shady can’t inspect at the moment) and the percentage versions of it. It’s not perfect yet but it’s an improvement.


  lumo-primary-text-color: '#00b706'
  lumo-body-text-color: '#FFFFFF'
  lumo-primary-color: '#00b706'
  lumo-primary-color-50pct: 'rgba(0, 183, 6, .5)'
  lumo-primary-color-10pct: 'rgba(0, 183, 6, .1)'

Interested. Resource from ? Can this be used if not? Also, the text issue work around I have used is here: Darkest-Nightz Theme , but would love to tweak with the vaadin-lumo-styles… Any insight would be greatly appreciated, thanks!

Yeah the lumo styles were what needed to be modified, I just didn’t have time to dig into what did what until today. I managed to fix the calendar and entity drop-down menus in the theme I posted today.

1 Like

Thanks all. I have updated the theme.

I like a lot this black theme. Thanks!!!

The only think that I would change are some badgets that appear like this:

however some other badgets appear nicer, like this:


Do you know how can I change the first one to the blue circle?

Best regards

Is there a way to get the garage door to turn yellow when it is in the open state?

  - entity: cover.garage_door
show_icon: true
show_name: true
show_state: true
type: glance
theme: Backend-selected

When you use the alarm panel, the default lovelace skin has a red badge on the top right corner to show the alarm is active (screenshot 1). Is there a way to have the same badge show up here? Currently it just comes empty (or maybe black and it is matching with the background?) and you can’t tell when the alarm is armed.
Edit- I’m pretty confident the badge turns black and blends into the background.

Default Lovelace skin badge

This Skin

As an FYI- when the alarm is not armed, it correctly shows the green badge

Thanks for your help.

New Unused entities page looks weird with the skin:

Also, disabled buttons are barely visible, for example on the Z-wave config page:

1 Like

I do not think this part is themable yet! Waiting for future update.

Updated the first post to fix this.

Both themes are now included in HACS!

Feel free to check it out at GitHub:

They are not listed in HACS for me. None of the themes are by the way. How to add them?