Blueprints Import - Error 404

I am unable to import blueprints, every time I get a 404 Error. I even tried the example on the help page, error 404.


Make sure the URL points to your instance, I have the same problem sometimes.
If this is the case, you have two choices:

  • Edit the URL on your browser’s address bar after you get the 404 and hitting enter.
  • Copy the URL of the import link, paste it in the address bar and edit it to point to your instance before hitting enter.


Same issue. I did validate that hass does resolve DNS correctly. I am using a cloudflare setup. wonder if that’s the issue.

So, once you get to this website:

Try typing your http://YourLocalInstanceIP:8123 (https if you changed that in config.yaml)

Then hit Update

That will take you to a new link that will prompt you to login to your HA locally, no cloudfare involved.

The same thing, even locally.

hass.lan without a port?
Is your HA running on port 80 or 443?

1 Like

You are missing the local port: hass.lan:8123, unless you changed it to 80/443 in your config.

It’s running on 443, everything else works except importing blueprints.

Same here 404, everything else works just fine, tried localip:8123 and FQDN , always just give 404: not found, I think its cause I am missing the my: in my config

Did anyone find a solution to this? I figured perhaps it was because the feature didn’t exist in the docker version, but I’m not sure. I run my instance through a HTTP proxy on port 443. I just get a 404 error as per the screenshots posted.

EDIT: Seems I worked it out - it needs the following integration enabled to work: My Home Assistant - Home Assistant