Bluetooth BCM43xx add-on failing to initialize on Raspberry Pi 3B


I’m having trouble to initialize the integrated bluetooth on Raspberry Pi 3B with HassOS 1.7, both 32bit and 64bit images. The add-on (v2.3) fails with following message:

Failed to write reset command
Can't initialize device: No error information

I’ve tried with two different Raspberry Pi units - same result.

Any ideas? Cheers,


The BCM add-on is not made for on HassOS. HassOS uses Bluez which is installed by default. Though there are some problems with it in the current version.

I’m trying to get MiFlora working with a new install of HASS.IO using HassOS with no success, is bluetooth basically broken in 1.7?

I am getting the same problem as well, any help would be great.

There are already two other topics about the Bluetooth problems in on HassOS. Please look at those.

I also have the problem with Bluetooth. Here is the log of my mistake
> Error setting up platform bluetooth_tracker

    Traceback (most recent call last):
      File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 183, in async_setup_platform
      File "/usr/lib/python3.6/concurrent/futures/", line 56, in run
        result = self.fn(*self.args, **self.kwargs)
      File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 72, in setup_scanner
        for dev in discover_devices():
      File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 50, in discover_devices
      File "/usr/lib/python3.6/site-packages/bluetooth/", line 26, in discover_devices
        device_id = _bt.hci_get_route()
    OSError: [Errno 19] No such device

Same issue on Raspberry Pi 3B+ with Hassio 0.74.2.