Bluetooth configuration problem

Hi,
I have a problem setting bluetooth dongle in my ha. I’m running debian bullseye with supervised installation. Both ha and debian are fully updated to the latest stable version.
When I reboot my comp I get this error Screenshot from 2022-11-24 19-49-58
On system when I run hciconfig -a I get this

hci0:	Type: Primary  Bus: USB
	BD Address: 00:1A:7D:DA:71:05  ACL MTU: 310:10  SCO MTU: 64:8
	UP RUNNING 
	RX bytes:696 acl:0 sco:0 events:30 errors:0
	TX bytes:417 acl:0 sco:0 commands:37 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0xdb 0xff 0x5b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'CSR8510 A10'
Can't read class of device on hci0: Connection timed out (110)

I installed dbus-broker and enabled it.
When I run sudo systemctl status dbus-broker I got this

     Loaded: loaded (/lib/systemd/system/dbus-broker.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-11-24 19:38:54 CET; 14min ago
TriggeredBy: ● dbus.socket
       Docs: man:dbus-broker-launch(1)
   Main PID: 482 (dbus-broker-lau)
      Tasks: 2 (limit: 9334)
     Memory: 4.3M
     CGroup: /system.slice/dbus-broker.service
             ├─482 /usr/bin/dbus-broker-launch --scope system --audit
  └─508 dbus-broker --log 4 --controller 9 --machine-id --max-bytes 536870912 --max-fds 4096 --max-matches 1310724182b6a9680abacc0f40 --max-bytes 536870912 --max-fds 4096 --max-matches 131072 --audit

It seems that after reboot bluetooth dongle doesnt work and it’s not recognized in home assistant.
But if I restart dbus-broker my bluetooth dongle is recognized but I get his


I can’t see in the menu configuration for network interfaces.
and I can’t open ssh web terminal because it’s waiting for supervisor to startup.
If I do hciconfig -a I get his

	BD Address: 00:1A:7D:DA:71:05  ACL MTU: 310:10  SCO MTU: 64:8
	UP RUNNING 
	RX bytes:103317 acl:0 sco:0 events:2477 errors:0
	TX bytes:4058 acl:0 sco:0 commands:248 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0xdb 0xff 0x5b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'homeassistant'
	Class: 0x000104
	Service Classes: Unspecified
	Device Class: Computer, Desktop workstation
	HCI Version: 4.0 (0x6)  Revision: 0x22bb
	LMP Version: 4.0 (0x6)  Subversion: 0x22bb
	Manufacturer: Cambridge Silicon Radio (10)

In my opinion something problem might be in the dbus socket and its avability to home assistant. I’m not sure is this a case, its my guess. But if it is I don’t know how to fix it.
Edit:
After checking some things I found out that mdns stoped running after I restarted dbus-broker. I removed avahi-daemon from my system but it didn’t changed anything.

This what I have:

lsusb
Bus 003 Device 002: ID 8087:8000 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 002: ID c0f4:05e0 SZH usb keyboard
Bus 002 Device 004: ID 1a86:7523 QinHeng Electronics CH340 serial converter
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg | grep tooth
[    3.418001] Bluetooth: Core ver 2.22
[    3.418039] Bluetooth: HCI device and connection manager initialized
[    3.418044] Bluetooth: HCI socket layer initialized
[    3.418046] Bluetooth: L2CAP socket layer initialized
[    3.418051] Bluetooth: SCO socket layer initialized
[    3.632748] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.632753] Bluetooth: BNEP filters: protocol multicast
[    3.632758] Bluetooth: BNEP socket layer initialized
sudo rfkill
ID TYPE      DEVICE      SOFT      HARD
 0 bluetooth hci0   unblocked unblocked
hciconfig -a
hci0:	Type: Primary  Bus: USB
	BD Address: 00:1A:7D:DA:71:05  ACL MTU: 310:10  SCO MTU: 64:8
	UP RUNNING 
	RX bytes:696 acl:0 sco:0 events:30 errors:0
	TX bytes:417 acl:0 sco:0 commands:37 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0xdb 0xff 0x5b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'CSR8510 A10'
Can't read class of device on hci0: Connection timed out (110)

I think that for some reason this adapter doesn’t have dbus communication. If I do

sudo systemctl restart dbus

I get his

hci0:	Type: Primary  Bus: USB
	BD Address: 00:1A:7D:DA:71:05  ACL MTU: 310:10  SCO MTU: 64:8
	UP RUNNING 
	RX bytes:108844 acl:0 sco:0 events:2608 errors:0
	TX bytes:4116 acl:0 sco:0 commands:256 errors:0
	Features: 0xff 0xff 0x8f 0xfe 0xdb 0xff 0x5b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'homeassistant'
	Class: 0x000104
	Service Classes: Unspecified
	Device Class: Computer, Desktop workstation
	HCI Version: 4.0 (0x6)  Revision: 0x22bb
	LMP Version: 4.0 (0x6)  Subversion: 0x22bb
	Manufacturer: Cambridge Silicon Radio (10)

My adapter is recognized by home assistant but I get unsupported system errors. I checked the docs and it says "The Bluetooth adapter must be accessible to D-Bus ". It’s seems to me that it isn’t accessible to dbus on reboot but if I restart dbus it became available but it breaks some things in ha.
Can someone help me out with this?

Ok, I got this working by restarting Network Manager and hassio-supervisor services. But I still got unsuported installation problem.
The problem is obviously related to dbus. When I do in ssh terminal

ha network reload

I get

Error: No network D-Bus connection available

I can’t believe it. In /etc/systemd/system/hassio-supervisor.service I just added a line like @k96hkh suggested in this thread and just done systemctl daemon-reload and volla.
No dbus errors, system is supported and everything is working.

After whole weekend trying to make my bluetooth adapter work, I think I found a permanent solution for it. I’m using debian 11 and I reverted all my editing to defaults. I upgraded my kernel to 6.0 from testing branch.
In /etc/apt/sources.list I added

deb http://deb.debian.org/debian/ testing main contrib non-free
deb-src http://deb.debian.org/debian/ testing main contrib non-free

For kernel I created /etc/apt/preferences

Package: *
Pin: release a=bullseye
Pin-Priority: 500

Package: linux-image-amd64
Pin:release a=testing
Pin-Priority: 1000

Package: *
Pin: release a=testing
Pin-Priority: 100

and upgraded my kernel. Bluetooth adapter is recognized on boot and I don’t see any errors or problems for know.
I hope this is the end of the road for me and my adapter.