Bluetooth Dongle issues


Looking for some help. I recently set up a home assistant server & have had nothing but issues trying to get bluetooth up & running. I think originally it was the dongle I was using so I purchased a new one that is on the approved list I’m using the UGreen CM390. I have tried this today after updating to the latest version of Home Assistant OS with no joy. The intigration show’s up but with the message “Retrying setup: Failed to start Bluetooth: adapter ‘hci0’ not found”.

The VM itself is running on a Dell 3040 with windows 10. I have HAOS running within a VM using Oracle Virtual Box as per the official guide & I set up the bluetooth USB the same as the Conbee & have included a screenshot below. As per a suggestiong I saw elsewhere I have turned off the machines main onboard bluetooth & disabled the bluetooth dongle within device manager but it seems to have made no difference.

Any help would be greatly appreciated as I’ve been tryig to get bluetooth working for weeks now & it’s just going nowhere.

Yeah I have the ZEXMTE BT-505 supported dongle and get the exact same error after a reboot on my dedicated pc running HA OS.

I managed to resolve it by pulling the dongle & reinserting with the PC up & running along with the VM. I then restarted the VM for good measure.

I was mostly just messing around & seemed to get it to work.