Bluetooth gone away

Hey dudes :slight_smile:

New User. When I first set up home assistant in virtualbox, the bluetooth dongle was found automatically and was working fine, it even found my lone bluetooth temp\humidity sensor that I did not know could be used. But it took control away from the VB host so the bluetooth mouse and keyboard stopped working on the host. Since the keyboard/mouse was more important to me I deleted the bluetooth integration and got control back in the VB host.

But today I set the keyboard/mouse up on a second logitech unifying receiver which freed up the bluetooth dongle for use in HA. The dongle was found in VB and I again set it to be used by home assistant. But this time HA did not find it. So I tried to install the bluetooth integration again but it now says “No unconfigured Bluetooth adapters found”. So how do I get HA to again see the bluetooth dongle?

Many thanks :slight_smile:

same problem here

I can see the bluetooth device in storage core device registry as a deleted device but I do not yet have the knowledge to screw with script files.

It is of course an assumption that this is what is causing the problem.

I’ve got the same exact issue. I even bought a new bluetooth adapter (one from the recommended adapters in the official bluetooth integration page) but I still get the ‘No unconfigured Bluetooth adapters found’ thing

Following - I have the BLE Monitor but get the “No unconfigured Bluetooth adapters found”

Not VB installation but HA Core on Armbian. I’ve faced with the similar error :“No unconfigured Bluetooth adapters found” when I’ve tried to run bluetooth integration ( HA ver. 2022.11.2 ). I’ve noticed I was able to run properly bluetoothctl command in linux terminal only as root user. Googling brings me to the solution to add “hass” user (under which homeassistant is running on my armbian ) into /etc/dbus-1/system.d/bluetooth.conf

<policy user="hass">
<allow own="org.bluez"/>
<allow send_destination="org.bluez"/>
<allow send_interface="org.bluez.GattCharacteristic1"/>
<allow send_interface="org.bluez.GattDescriptor1"/>
<allow send_interface="org.freedesktop.DBus.ObjectManager"/>
<allow send_interface="org.freedesktop.DBus.Properties"/>
</policy>

and restart bleutooth service:
sudo systemctl restart bluetooth
after that HA bluetooth integration has successfully discovered my dongle and other bthome compatible sensors have been appeared automatically under BTHome integration.
links to the sources:
https://forums.raspberrypi.com/viewtopic.php?t=108581

Eugene,
Thanks for responding. Sorry I’m so new to this.

I’m not sure what a VB installation or Armbian are. I don’t use Linux. I’m running HA core on a Raspberry Pi4.

Is this something I can add to my configuration.yaml file or something?

Justin,
Armbinan is the special linux distributive for various SBCs (particulary mine is orange PiOne ) similar to Raspberry Pi OS (previously called Raspbian) which yours HA core is running on… USB Adapter (or the embedeed one) has to be set up on the OS level before it will be discovered by HA. So, please:

  1. check if bluetooth stack (bluez) is installed and working:
    sudo systemctl status bluetooth - this command should tell you if it’s up and running; if yes, check the status of your ble hardware:
  2. bluetoothctl show
    I’ve attached the screenshots taken from my system:
    1

    2
    bluetoothShow

and, FYI I’m using Bluetooth integration in passive mode ( which is recommened as BLE Monitor replacement ) and the usb dongle (based on CSR8510A10 chip) . It works with 3 BTHome sensors
flashed with custom firmware GitHub - pvvx/ATC_MiThermometer: Custom firmware for the Xiaomi Thermometers and Telink Flasher via USB to Serial converter )

many thanks

Is this the command to run? “sudo systemctl status bluetooth”
If so, where do I run that (sorry I’m not familiar but eager to learn).