Bluetooth Proxy crash after 2024.6


After updating to esphome 2024.6, my esp32 bluetooth proxy crashes.

It seems to get through the setup() phase, and then crashes with an error saying “loopTask” did not reset the watchdog in time. It will then reboot itself and go into a boot loop outputting the same error.

I’m using these boards: ESP-WROOM-32 (

I have some brand new extras of those, so I tried installing the configuration on a new one, but the issue persists.

Here is a snippet of the log showing the error.

[D][wifi:625]: Disabling AP...
[C][api:025]: Setting up Home Assistant API server...
[I][app:062]: setup() finished successfully!
[D][esp-idf:000][wifi]: I (7251) wifi:
[D][esp-idf:000][wifi]: <ba-add>idx:0 (ifx:0, 7a:45:58:1d:97:5d), tid:0, ssn:8, winSize:64

E (11276) task_wdt: Task watchdog got triggered. The following tasks did not reset the watchdog in time:
[11:03:11]E (11276) task_wdt:  - loopTask (CPU 1)
[11:03:11]E (11276) task_wdt: Tasks currently running:
[11:03:11]E (11276) task_wdt: CPU 0: IDLE0
[11:03:11]E (11276) task_wdt: CPU 1: IDLE1
[11:03:11]E (11276) task_wdt: Aborting.
[11:03:11]abort() was called at PC 0x40137ba4 on core 0
[11:03:11]Backtrace: 0x40082bfa:0x3ffbe3f0 0x40091ec9:0x3ffbe410 0x40097f2e:0x3ffbe430 0x40137ba4:0x3ffbe4a0 0x400835f5:0x3ffbe4c0 0x401cdeff:0x3ffbc780 0x401382f5:0x3ffbc7a0 0x400932a0:0x3ffbc7c0
[11:03:11]ELF file SHA256: df65a9a161505cc2
[11:03:11]ets Jul 29 2019 12:21:46

Here is my esphome configuration for this device:

  name: esp32-bluetooth-proxy-e46b20
  friendly_name: Bluetooth Proxy
  esphome.bluetooth-proxy: github://esphome/firmware/bluetooth-proxy/esp32-generic.yaml@main
  name: ${name}
  name_add_mac_suffix: false
  friendly_name: ${friendly_name}
    key: HIDDEN
  - platform: esphome

  ssid: !secret wifi_ssid
  password: !secret wifi_password

Initially I had no ota block, but I added that to see if that would help, but it made no difference. I’ve tried a few other configurations using the examples from the documentation, including specifically specifying the board type, but no luck.

Did my esp32 suddenly become unsupported? I didn’t see anything in the changelog / breaking changes that would affect me.

Appreciate any help.

EDIT: Here is some additional version info from the logs that may or may not be useful:

boot: ESP-IDF 4.4.7 2nd stage bootloader
boot: chip revision: v3.1
boot.esp32: SPI Speed      : 40MHz
boot.esp32: SPI Mode       : DIO
boot.esp32: SPI Flash Size : 4MB
App version:      2024.6.6
Compile time:     Jul  8 2024 11:00:28
ESP-IDF:          4.4.7
Min chip rev:     v0.0
Max chip rev:     v3.99 
Chip rev:         v3.1

Yes you did, it is included by the package.

In fact ota has been extended to use an http_request update method. Unknown whether that would introduce this error.

Edit: seems to be the problem, see

Wow, great find. The full yaml config at the bottom of that github issue worked for me, and i’m back up and running. Thanks

1 Like