Bluetooth Tedee Go lock not discovered


I’m trying to get my Tedee Go connected lock recognised by HA via Bluetooth, but without success. I don’t have the bridge, so I want to connect it to HA via Bluetooth using HomeKit integration.

I run HA in a docker container on a Raspberry. The Bluetooth integration is properly configured, I can see it in the list of integrations and when I run a bluetoothctl from inside the container, I can see the Bluetooth devices (I can see the MAC address of my connected lock). Unfortunately, the device is not found by HA.

I did reset the lock by putting it upright and pressing the button. It is now disconnected from my phone, but I can’t get HA to detect it.

On my installation, I have configured the docker-compose file with :

- /etc/localtime:/etc/localtime:ro
- /run/dbus:/run/dbus:ro

I installed bluez and dbus-broker (it seems to work).
When I connect to the docker and run bluetoothctl, I get :

docker exec -it homeassistant bash
HA:/config# bluetoothctl
Agent registered
[CHG] Device XX:XX:XX:XX:XX:7A RSSI: 0xffffffbd (-67)
hci1 type 6 discovering off
[CHG] Device XX:XX:XX:XX:XX:7A RSSI: 0xffffffbe (-66)
hci1 type 6 discovering on
[CHG] Device XX:XX:XX:XX:XX:7A RSSI: 0xffffffbe (-66)
[CHG] Device XX:XX:XX:XX:XX:7A RSSI: 0xffffffb5 (-75)

And this is the MAC address of my lock.

I don’t know what else to do, could you help me?

Thanks in advance.

Best regards