Bluetooth tracker iphone max issue

Hello! We have 3 devices at home - iphone x, iphone 8, iphone xs max. I started using bluetooth device tracker and it is great for automatically turning on and off alarm system. iphone 8 and x are fine, but there is going on smth strange with xs max
When I open bluetooth settings - everything is fine, HA can see it, but if I go to main menu - HA looses it in 2 minutes (because consider_home: 120)
It seems, that HA can see xs max only if x max is in active search of bluetooth devices.
What can be done?

Hey @Argo,

My partner’s new XS doesn’t seem to want to play nice with the BT tracker either.
It adds to the known_devices.yaml just fine when records are deleted.
My XS Max is just fine.

Any other XS users out there? Perhaps someone running a dev or public beta?

Perhaps something that will be fixed with iOS 12.1

Hmm. Not sure about this. My XS Max last reported via BT 3 hours ago. Still says I’m home which is correct.

I’m running iOS 12.1 and the beta HA app. I know this doesn’t answer any questions.

If it is possible, try it out later. My father’s phone was not detected at the morning, nut he came home in evening and Home Assistant detected him. And the next evening again can not find hos phone. Only sees phone if I open bluetooth settings on iphone. If then I open mail menu - Home Assistant looses it

That’s rather strange. I’ll keep an eye on it.

I tried to find phone from computer and I see the same thing. When bluetooth settings are open - mac can see it, when I close - can not. BUT! The same thing happened with another device which is just fine with HA. So, as I understand, HA is kind of connected to phone, it is not stupidly searching every 12 seconds. Still have no solution.

Similar issues with iphone 6s - bt tracking works fine for a couple of hours when I’m at home but then something weird happens … HASS losses my phone and it looks like Bluetooth device on my phone goes into weird state - it disconnects Apple Watch and the only way to reconnect it back is to turn BT device off and back on. After toggling BT device HASS starts seeing it again and it again works for a couple of hours…

Hi! I have tried to reset network settings on iphone and everything seem’s to be ok for two days now.

Thanks for the hint! trying it out now.

Hey there! Did it work for you?

In a way it did - iPhone stopped loosing Bluetooth devices (Apple Watch/AirPods) but Bluetooth tracking isn’t working too well:( plus started hitting interference issue with 2,4GHz WiFi (HASS was loosing all y smart lamps). So I’ve disabled Bluetooth for now, thinking about other device tracking options.

I experience the same here in my home. My Iphone 8 has been working flawless for 3 months now. I am really impressed with the bluetooth tracker, combined with a NMAP i have never had problem with my lights going off. But my wifes Iphone X does not work all, seems to only be discoverable for HASS when the Iphone is in bluetooth search mode.

Anyone figuring this out? I have tried to restart the network setting and phone but can`t get it to work.

Hi! Try to discover your wife’s x from another device (i tried from mac). If the behaviour is the same - call to apple. Seems like they have some network issues with 12 ios on some devices.
My father had issues with 4G as well and I found some topics ftom other users.

Any luck on this anyone? I’ve recently upgraded iPhone X to XS Max and have found the bluetooth device tracker has fallen apart. Whereas the bluetooth tracker worked flawlessly on the X, it isn’t working at all with the XS Max.

The one exception is if I open the bluetooth config setting page on the XS Max, then it quickly appears as “home”, but disappears again when I close the setting page after the consider_home timer expires.

Very frustrating: WiFi (nmap) works pretty well, but is not perfect. Combining WiFi with bluetooth using a bayesian sensor fixes it almost flawlessly. Won’t be much use if I have to rely on WiFi alone.


Hello! Did you try to reset network settings?
I had no issues after that

It’s a brand new phone, but OK - I’ll give it a go…

My fathers iphone was as new as yours:)

Ha! OK - tried that, but no help. Bluetooth still not showing up. On top of that, lost my saved wifi networks…

Sorry, it was the only thing I know to work (in my case)
Let’s see if someone else has a solution

No worries. It’s mighty annoying after having been so reliable for so long on the previous phone. Am wondering whether it is to do with the introduction of Bluetooth 5.0 in the XS iPhones.