Bluetooth tracking on HassOS not working

I’m on the new 64bit HassOS on my rpi3B. I was happy to see people saying in the release thread that Bluetooth tracking should work now. But it won’t work with me. I can put:

  • platform: bluetooth_tracker

In my config but my known_devices stays the same untouched with a last modified date of last week. I was really looking forward to this! Has someone got it working? And if so, how?

1 Like

I too am noticing this. Used to be rock solid with the Bluetooth add on in resinOS. I am also running 64bit on an RPi3.

I am using the same bluetooth config from my previous resinOS install that had been working fine for over 6mths or more.

Funny you are saying that it worked on resinOS. The last time I saw this working was before was born.

Really? I’ve been using it on for awhile, works great.

Definately was working great (like really great!) on with the original resinOS implementation and the Bluetooth addon. Now with the new hassos and built in Bluetooth support, all of my location based automations are stuffed and it definately isn’t working!!! That makes me very sad.

Anyone have a fix worth noting? That is, short of rolling back to on resinOS.

Curious, what version of HassOS are people running that are having issues with Bluetooth? I’m running 1.7 and it’s broken (I upgraded it from the —> system menu. I can’t confirm if this was broken in the previous version I installed from the image (1.5 I think) so curious to hear from others.

It’s working fine for me with 32-bit HassOS on a PI 3B.

I’m running 1.7 on the 64-bit version of HassOS and the Bluetooth tracker is not working.

I can confirm that bluetooth is working ok after I downgraded to the 32bit version of HassOS (v1.7) on my RPi3. Steps as follows:

  1. Take a snapshot and downloaded it.
  2. Flash SD card using Etcher with the latest 32bit HassOS image
  3. Copy the snapshot back to the /backup folder
  4. Hit the refresh button in the Hass.IO --> Snapshots menu and restore the snapshot.

Once a restore has completed, I have found it is good practice to again stop HA, delete /config/home-assistant_v2.db and restart HA.

I have similar question. Is Bluetooth or BLE tracking working in on RPi3 b+?

I have installed Bluetooth BCM43xx Add-on but I think that b+ is using different chip for Bluetooth?

Same issue. Funny enough it did work when I ran the 64bit image. Stopped working when I changed over to 32bit.

How weird! I’m on HassOS 64 bits and bluetooth tracker is acting up on me too. How do I check what my version of HassOS is, and how do I confirm whether I’m actually running a 64bit version or just 32 bit?


I just joined HassOS and I too confirm having issues with Bluetooth. I’ve installed supervisor 115 + HassOS 1.7 32bit right from the start (no x64 downgrade or anything) and Bluetooth isn’t working out of the box. I’ve even installed the “Bluetooth BCM43xx (ResinOS)” addon to see if it would solve it. I installs fine but will give errors upon launching. The logs show:

Failed to write reset command
Can’t initialize device: No error information”

I wonder if re-installing from a backup as some mentioned above could help?

Same issue with HassOS 1.9 (Hassio Supervisor 125). When I SSH to the PI (3B+) and use bluetoothctl I get a

No default controller available

Is the bluetooth chipset supported for hassio and Pi 3B+? Do I need to enable something?

Remove the BT add-on , it is only for ResinOS.

BT tracking should work pretty much out of the box. Just make sure you have the device_tracker entry in your configuration.yaml file. As devices are discovered, they will populate known_devices.yaml file.

  - platform: bluetooth_tracker
    interval_seconds: 15
    consider_home: 150
    track_new_devices: yes

Thanks, trying to get the plant sensors to work and need to find their mac address. But the tooling (bluetoothctl) does indicate it has no controller. I added the device_tracker section now, lets see what that returns.

Since you are running in a docker container, you won’t get all of the same tools as you would in the base OS. Are your plant sensors std Bluetooth, or Bluetooth LE devices?

Somehow Hassio supervisor needs to expose the bluetooth device to the home assistant system. I cannot find any reference to an active bluetooth controller. The bluetoothctl responds by indicating there is no controller.

The plant sensors I have are LE sensors, however I also do not see any flic buttons or the nuimo controller. All bluetooth devices.

So I m wondering if the Pi 3B+ with Hassio has support for bluetooth?

I am running hassio .75.3 with hassos 1.9 on a pi3. I have bluetooth devices that I track, but these are not LE devices. There is a different tracker component for LE devices, but it has a warning about potential performance impacts.

I think there were a couple of projects looking at LE trackers, one of which is HappyBubbles. I can’t recall the other one, but they both use MQTT to send the state data over to HA.

Update: This one looks interesting if you have a consistent list of LE devices you want to track:==>