BOM weather sensors and yr weather predictions now unknown in hassio GUI?

Does anyone know if these error messages in the hassio log like below are something to do with my loss of BOM Sensor data and YR weather prediction data in hassio, they are being shown ‘unknown’ when opened now ?

Retrying in 15 minutes: Cannot connect to host ssl:True [Try again]

I just tonight successfully updated hassio to 0.65.3 via the hassio GIU page in case that helped, so I assume that www access is no issue from the Rpi hosting hassio since it could update. Yet the BOM weather and YR weather badges are still all ‘unknown’ (and have been for some days now).

Anybody know where I should go looking in hassio for a problem with externally fetched sensors like weather sites?

Edit: I just noticed that Pushbullet also seems to have stopped sending messages to my phone. Possibly all related but don’t know why. Rebooted my router just in case but nil change.

Update: yr weather sensor data came back this morning by itself, and has updated a few times today fine. BOM sensors still not around.

Still no go with my BOM (Bureau of Meteorology) weather sensor platform. I have yr weather sensor working again, but not BOM or it seems Pushbullet services. Have rebooted a few times but did not help.

Does this lump of log errors mean anything to somebody that might point me to a solution ?

2018-03-13 22:10:25 ERROR (MainThread) [homeassistant.components.sensor] Error while setting up platform bom
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/urllib3/”, line 141, in _new_conn
(, self.port), self.timeout, **extra_kw)
File “/usr/lib/python3.6/site-packages/urllib3/util/”, line 60, in create_connection
for res in socket.getaddrinfo(host, port, family, socket.SOCK_STREAM):
File “/usr/lib/python3.6/”, line 745, in getaddrinfo
for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -3] Try again

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/urllib3/”, line 601, in urlopen
File “/usr/lib/python3.6/site-packages/urllib3/”, line 357, in _make_request
conn.request(method, url, **httplib_request_kw)
File “/usr/lib/python3.6/http/”, line 1239, in request
self._send_request(method, url, body, headers, encode_chunked)
File “/usr/lib/python3.6/http/”, line 1285, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File “/usr/lib/python3.6/http/”, line 1234, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File “/usr/lib/python3.6/http/”, line 1026, in _send_output
File “/usr/lib/python3.6/http/”, line 964, in send
File “/usr/lib/python3.6/site-packages/urllib3/”, line 166, in connect
conn = self._new_conn()
File “/usr/lib/python3.6/site-packages/urllib3/”, line 150, in _new_conn
self, “Failed to establish a new connection: %s” % e)
urllib3.exceptions.NewConnectionError: <urllib3.connection.HTTPConnection object at 0xb3cb9f70>: Failed to establish a new connection: [Errno -3] Try again

My BOM on latest hassio works fine.

Thanks. My problem then, but I have no clue where it might be as I didn’t modify the config.

Hmmm, did a reboot via hassio system page and this time BOM returned as well.
Pushbullet was a red herring, the Android App was inactive or stopped…
HA back to normality again.