Bond Integration problems

I have 7 fans in my house which all have separate universal remotes made by Bond (these function in the Bond Home app as “Smart By Bond” fans). I don’t actually have a Bond Hub.

I never did anything with them in HA, but I wanted to add something today and realized that none of them were connecting to the Bond Integration that I had set up months ago (and more or less forgot how I did it).

So I deleted all of the fans within the Bond Integration and tried to add them again, but every time I try to add one, I get the message “Failed to connect”. These are the steps I am taking:
-Go to /config/integrations
-Click “Add Integration”
-Select “Bond” from list
-In “Host” I am inputting the IP address of one of the fans (I have tried with and without “http://”)
-In “Access Token” I am inputting the local token from that fan
-Click “SUBMIT”
-Receive error message

I have tested via CURL using the token and it is connecting properly, so I know I have a functional IP address/token pair.

Any thoughts?

Hey @Kethlak , I am having the exact same issue as you after I updated my bond hub from firmware 2.x to 3.x. I am wondering if the integration requires an update.

I have submitted a Github issue as well for this: