Boot hang - "Switched to clocksource tsc"

I have been running Home Assistant for almost a year now without problems. Last night I did an update of the HA OS / Core, and when it tried to reboot it got stuck on the message “clocksource: Switched to clocksource tsc”.

I am running an Intel NUC with Windows 11, using MS HyperV. I noticed that the timezone on my windows had changed to a different time zone, so I rest that to the corect one, but this did not resolve the problem. I also tried to add a registry key so that the system uses UTC time zone as suggested here: Kernel boot suddently getting stuck at “clocksource: switched to tsc” / Newbie Corner / Arch Linux Forums but also did not work

Before the problem started I had not done anything on the NUC - no BIOS changes, no setting updates, no new hardware, nothing. I just leave the NUC to run my home and don’t use it for anything else.

I would really appreciate some advice to resolve this


Windows will take care of that part for you, so look at what updates have been applied there in the time around the problem.
Remember that some updates can be applied days before and first really take effect when Windows or the service is restarted.

1 Like

I uninstalled any windows updates that were applied int the last few weeks and rebooted, but still no luck :frowning:

Ok I eventually created a new VM, used the latest Hyper-V disc image, booted up and in the initial setup selected the option to do a full restore from backup. The backup was made just prior to the updates (before I started getting this problem).

After restore, the system was working fine. I then checked for updates and updated all components in HA. I restarted both the VM and host servers just to be sure and everything seems to be good now, even after reinstalling the windows updates.

No idea why that happened, but seems to be resolved.