Boot loop ufter upgrading to latest Home Assistant OS 10.5

Hi, I run HAOS on a proxmox environment.

Yesteday I upgrade HaOS to 10.5 and now after a rebook the system is locked in boot loop.

The only thing I see in proxmox console is

Booting 'Slot B (OK=1 TRY=1).

any suggestion ? I tag also @tteck just because I used his script.

I would suggest. Create a bug here.

No solution for you. But I think the devs would like to know.


I firstly opened a topic here just to be sure it’s a bug instead of some config error or my side.

I didn’t change anything actually just rebooted but maybe there’s some missing point

Have you searched the issue?

yes but honestly the topic was for Proxmox 8 while I’m still in 7.x. I will try to apply the suggestion proposed and let you know.


OK I tried changing machine to q35 and remove pci.

The situation changed but I still can start HA.

I see that I have no space in local-lvm and summary says io-error.

Any hint?

Hardware > Hard Disk > Disk Action > Resize
add 8GB and then check if the virtual machine is able to start.

I added 12 GB but still see io-error.

local-lvm is still 100% occupied.

Oh, it appears to be time to increase your local storage capacity within the Proxmox VE by either upgrading or adding more storage.

you mean physical storage?

I’m asking because I thought that 250GB were enough for just HA + Nextcloud. I think the problem is due to the snapshot made by frigate during my holidays (so a temporary requirement of space).

There’s a way to clean it before adding extra space?

Yes, what is the capacity of the hard drive installed in your machine? delete the snapshots.

ok. Have to find a way (frigate is running as HA addon). You know how to login? I tried using winscp but it does not work

Sorry, I don’t use addons.

No problem. You already helped me a lot. I’ll find a way :slight_smile: (and post here for the future in need)

ok. I had to delete nextcloudpi in order to have HA WM works ('ill try to recover it from backup later).

Now I no longer need that HA VM has so much space. How can I reduce it?

I changed config in Proxmox config to 100G and i can see correctly reported in lvm-thin but looking inside home assistant i see that space of HDD is still 132.

Does anyone knows a way to reduce hdd size?