Bought recommended DIGITUS DN-30210-1 adapter, doesn't work

I already had a ASUS BT500 bluetooth adapter, but it would (rarely) sometimes go into a deadlock where it would be stuck at the same readings.

I thought I’d just buy one of the recommended adapters (DIGITUS DN-30210-1) from

Now that I have it, I can’t get it to read readings… Ever… Devices simply show as “Unavailable” if I use it in place of the current ASUS BT500 adapter.

I thought huh, maybe it is somehow gotten hardcoded to the integrations using bluetooth such as (ruuvitag_ble). So I tried reordering the USB-devices so that instead of the new adapter being added as hci1 now reordered as the first USB-device hcid0/usb0 by editing the hardware in the virtual machine configuration.

It still doesn’t work.

Why would a recommended adapter like this simply refuse to work with homeassistant? Using it from the commandline with bluetoothctl shows devices just fine! There is seemingly no errors in log, nothing wrong with this adapter, all of the bluetoothctl commands works as expected… Except homeassistant doesn’t seem to record device updates or devices from it.

I have also tried enabling “passive scanning” as the only configurable option in the Bluetooth device settings.

Homeassistant VM is of course updated to the latest version and all.

What is going on?

The fastest BT adapters are the espHome proxy. All you need is an esp board and flash it with espHome.

You said VM install but that could be anything. BT is tricky to set-up if you are not using HAOS install on whatever version of hardware because of all the dependencies.

Ready-Made Projects — ESPHome.

Sad that this is the only solution. If I understand this correctly all this ESP32 microprocessor is serving is a bluetooth adapter, because for whatever reason bluetooth adapters don’t work properly with linux or homeassistant anymore? Is this unique to homeassistant?

Its a proxmox server with a HAOS image like

Bluetooth and usb pass-through has its issues.

HA will only find devices which have an integration. Even with a ESP32 bluetooth proxy, if your devices don’t have an integration, they will not be found.

Right… I did blacklist all the modules on the proxmox server


blacklist bluetooth
blacklist btrtl
blacklist btintel
blacklist btbcm
blacklist btusb

The other adapter works ok despite the once-in-6-months deadlock on sensor updates

I don’t know why that is sad. The Nabu-Casa Developer for the firmware has tweaked this to the point that it is faster than a usb stick. It is scalable, add as many as you need. It is cheaper than a usb stick. If you go with an Ethernet based esp there isn’t even any radio timeshare slowdowns you mentioned.

Well if its that cheap I won’t hesitate in buying one…

Please clarify one thing tho…

For instance this M5Stack ESP32 has no bluetooth onboard it seems, so where does the bluetooth connectivity come from?

Sure, but they use the ruuvitag_ble integration, which is official (RuuviTag BLE - Home Assistant) so it does have an integration.

They have a couple recommended in the post I gave you, but I just bought a pack of 3 random esp32 from amazon, loaded them, and they serve me well. Mine run as WIFI.

This is what I don’t understand… They don’t seem to have bluetooth connectivity on the boards?

Almost all the ESP32 chips have builtin Bluetooth on the chip. I think there is 1 obscure variant I saw a sheet on once that doesn’t but I’ve never seen it on a place that sells the little boards to hobbyists.

I’ve bought 6 of these and they are fine…

And obviously the ones in the espHome link I sent are also fine.

That would be the s2 mini, the D1 mini’s big brother.

Avoid that & you should be mostly fine.

1 Like

I still don’t understand why the adapter doesn’t work… I mean it should… It doesn’t seem to be related to passthrough issues cuz it works perfectly from HAOS terminal with bluetoothctl

How do you connect it? Did you use a good USB extension to get it away from the server, any usb3 ports, and any other radio (zigbee, wifi, zwave)?

I simply plug it back in because its only on the other side of the wall it needs to reach

Get it about a meter or two away from all other radios and metal and stone.
Put it on a good extension cord, then see what happens.