Brand new Hassbian install -WeMo broken

Tried rolling back to .54, same error. I usually use statically assigned Wemo, but commenting out the static assignments is giving me the same error. Help?

2017-10-08 16:28:06 ERROR (MainThread) [homeassistant.setup] Error during setup of component wemo Traceback (most recent call last): File “/srv/homeassistant/lib/python3.5/site-packages/requests/packages/urllib3/”, line 386, in _make_request six.raise_from(e, None) File “”, line 2, in raise_from File “/srv/homeassistant/lib/python3.5/site-packages/requests/packages/urllib3/”, line 382, in _make_request httplib_response = conn.getresponse() File “/usr/lib/python3.5/http/”, line 1198, in getresponse response.begin() File “/usr/lib/python3.5/http/”, line 297, in begin version, status, reason = self._read_status() File “/usr/lib/python3.5/http/”, line 258, in _read_status line = str(self.fp.readline(_MAXLINE + 1), “iso-8859-1”) File “/usr/lib/python3.5/”, line 576, in readinto return self._sock.recv_into(b) socket.timeout: timed out

Moved to; everything is working now