Brand new Home Assistant Green, doesn't properly install itself

I’ve unpacked my brand new Home Assistant Green and connected it first to a LAN port on my FritzBox router and then plugged the power cable in. It took a while and it became reachable from my browser. Unfortunately I’m stuck at the welcome screen and the very first warnings/errors in the log are:

[supervisor.dbus.timedate] No timedate support on the host. Time/Date functions have been disabled.
[] Can't update PulseAudio data: Failed to connect to pulseaudio server
[supervisor.utils.whoami] Whoami service failed with SSL verification: Cannot connect to host ssl:True [SSLCertVerificationError: (1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: certificate is not yet valid (_ssl.c:1006)')]
CRITICAL (MainThread) [supervisor.core] Fatal error happening on load Task : cannot access local variable 'data' where it is not associated with a value
[] 'Updater.fetch_data' blocked from execution, no supervisor internet connection

Then most follow-up warnings/errors are of the same format:

[] <SOME MESSAGE> blocked from execution, no supervisor internet connection

It looks like it can’t connect to the Internet, but I’m not sure why. If I put my notebook into the same RJ45 port in the router Internet works. The router is a DHCP server and gives out an IP to the device, I hope this is okay? I think so, otherwise the welcome page would not be reachable from within the network?!

Any help? I’m an absolute Home Assistant newbie and bought the Home Assistant Green in order to not run into any trouble when setting it up.

Best regards,

If of interest: my Home Assistant observer page shows the following information:

Supervisor:	Connected
Supported:	Supported
Healthy:	Unhealthy

Best regards,

I’ve checked out the Setup of the Supervisor failed - Home Assistant page

  • DBUS doesn’t seem to be the problem?!
  • Next up is restarting the supervisor
    ** Can’t use CLI as I don’t have an access token yet
    ** Can’t go to Settings → System → Hardware as I can’t login yet

So no help there :frowning:

I assume you have tried, unplug/power it of, boot again ?

Yes if you see this from another IP device, you Green have a valid IP, in your Network ( Which you can verify in your Router

However, i have No idea how your Router Settings are , whether “New LAN Devices” is blocked from internet access by “default” or setting you have made, Also check your Firewall-Settings
( Make sure HA’s IP is “allowed” )

Hi! Yes, I’ve turned it off and on again multiple times already. Didn’t help.

No, all devices can access the Internet. There are no outgoing firewall rules - are there any incoming ports that need to be opened?

Try this

ha dns options --servers dns://
ha dns restart
network info

(If you can connect keyboard and monitor)

No, definitely Not, if the installation instructions doesn’t says So

What you can Do, is plug it in, and go take a brake and leave it alone, for awhile

As “things” run fast in HA’s development, you might have got an “early release” , dunno where you bought it, or how much “time” you gave it, but it needs to “check” for new release/versions etc, download and install this, thou that should be “visible” in the log ( I Don’t know as ive never booted a preinstalled device )

So have patience , leave it alone, check in on it , when your patience runs out, then give some more time :slight_smile:

Sounds like he haven’t got past the On-boarding phase yet, not sure he would get a cli then

Once you have the onboarding screen, I think you should have access to the console

@francisp: unfortunately I don’t know how to access the console from the onboarding screen. There is no link or something like that.

I think I solved the problem. My router had DNS over TLS active and it looks like this device is from a different generation that can’t use DNS over TLS.

Wish me luck that everything works now :slight_smile:

Best regards,

1 Like

We’ll found out soon :slight_smile: , for sure as you say, Keyboard And Monitor is 1st step here

He mend connect a keyboard and a monitor direct to your Green, it’s always good to have this “option” available when booting a “headless” Device ( And you will need this in the future anyways )

Indeed, you can’t. You need to attach a keyboard and monitor to your green to access the console.

It’s always DNS :slight_smile: