Brand new install; cannot install addons

I burn a fresh copy of 7.6 onto a good SD card.
The system starts up fine, I make a new account, I’m in…
I go to AddOns, and NONE of the addons will install, giving a 404.
Yes, I’ve heard one issue is free space. But this is a 32GB card with a FRESH install.
I’ve heard an issue is DNS, but not sure how to confirm it’s working inside the container. I can go to ‘login’ from HA prompt and do an nslookup, so I know in general the Pi gets DNS, but within the container? How do I know?

This is a FRESH install. How can it not be working?

If you run the command ha resolution issues do you see anything?

“ha resolution info” shows no issues, no unhealthy, no unsupported. Only suggestions, and that just wants me to do a backup.

Here’s the error from the COMPLETELY FRESH 7.6 install on a 64GB card that has never seen HA on it. I install, I create an account, I go through setup, I go immediately to AddOns. I get this error…

Failed to install add-on

Can’t install homeassistant/aarch64-addon-mosquitto:6.1.1: 404 Client Error for http+docker://localhost/v1.41/images/homeassistant/aarch64-addon-mosquitto:6.1.1/json: Not Found (“no such image: homeassistant/aarch64-addon-mosquitto:6.1.1: No such image: homeassistant/aarch64-addon-mosquitto:6.1.1”)

Ok so couple things to test then.

  1. Can you install an addon from the community addons repo? Those are hosted on rather then dockerhub. Might be an issue with being able to access dockerhub as opposed to all addons
  2. Since it sounds like you have access to the host OS shell, can you try a simple test for me? Just try entering docker pull alpine. Alpine is one of core images hosted on dockerhub used as a base in countless containers and addons. If you’re having a general dockerhub issue that should make it apparent and perhaps show more details.
  3. If at this point its apparent that your issue is with dockerhub, then if you don’t mind could you share what country you’re from and what your ISP is? Does it perhaps match others on this issue? It seems dockerhub is being blocked in some parts of the world, I’m not sure why. There’s a workaround on that issue which is the best we can offer right now.

If I’m totally off base and tests 1 and 2 make it clear this isn’t a dockerhub issue then let me know and we can try some other tests.

Could it be that after burning the image onto the SD and booting, the partition is still set at the minimum and was not expanded to fill the available space of the card?

What does ha host info say for disk_total and disk_free? Is it the numbers you expect or much lower?

Thanks to all for your help. All signs point to a Gateway issue on my network. Seems it’s having some issues resolving certain addresses. I have a new gateway on order and will update here if that’s not the issue. Also seeing issues with connecting to my NTP server (had to change from Cloudflare to Google, but then it worked, so I assumed a CloudFlare issue) and some non-HA-related connectivity challenges.

I came here with the same issue. Some addons would fail with the same error. Some would work with no trouble.

@CentralCommand made a few suggestions and the third one struck a chord in my head. “…could you share what country you’re from…”

I had recently turned on the Country Restriction feature in my gateway. Allowing only connections from the US.

I disabled that option and the addons that gave me grief previously now installed without issue.

I replied to this old thread to include my solution in case it might help others.

Thanks, @CentralCommand.


1 Like

I changed the firewall settings in my router from medium to low and I can now install add-ons. Maybe it was blocking needed ports?

Hello all,

Same issue here : fresh install on 64 gb card, data partition takes all free space and I use opendns but when i try to install teminal & ssh or google drive addons I get 404 error just like Jeppedy here : Brand new install; cannot install addons - #3 by Jeppedy

Any idea please ?

Finally terminal & ssh has installed without changing anything… Maybe google drive backup will install one day :confused: