Bricked after update to 2021.9.0

I have a problem after updated a few days ago to 2021.9.0.
I’m running HA OS in a Raspberry Pi 3 Model B.

After updating, HA restarted a few times. Now there is no access to port 8123, but I have access to the console.

It seems HA is never started up completely.
I noticed there is a 2021.9.1 version, so I tried to update.

I tried ‘core update’ but in supervisor logs I can see: “can’t execute update while a task is in progress”.

After half an hour of waiting, the situation is still the same.

Same message happens when I try to restore a backup using the CLI.

What can I do? Any suggestions?

Thanks in advance,


Put a semi-colon ; on it’s own line at the end of your configuration.yaml file and use the CLI to restart the host machine:

ha ho reboot

The semi-colon will cause your home assistant to fail the configuration check when it attempts to start and will stop the boot-looping. Hopefully the reboot will stop the running task that is preventing your use of the supervisor.

Use the console to update to 2021.9.1

ha core update --version 2021.9.1

Remove the semi-colon from your configuration file and restart.

Props to cogneato for this method on Discord


That made it! While doing it I noticed a new version (2021.9.2), so I have now the latest version running.

Thanks a lot!!

I have tried twice to upgrade to 2021.9.1 then 2021.9.2 using the following commands. sudo su -s /bin/bash homeassistant, source /srv/homeassistant/bin/activate, pip3 install --upgrade homeassistant. All of the outputs say the installation completed but when I try to connect with the browser ( I never connect. When I reinstall 2021.8.8 with pip3 install homeassistant==2021.8.8 every thing works. Any help would be appreciated.