Bricked my brand new Home Assistant blue (SOLVED)

Something went wrong when I tried to go through the onboarding process using a snapshot from my previous version. Now, the thing is entirely unresponsive. I’m assuming I want to reinstall the OS from the images available. The problem is I need some help flashing the ?emmc? module. I got the case open but I’m not sure where to find the module, how to remove it, and how to flash it.

Anyone know of a good reference?

The HA Blue is a Hardkernel ODROID-N2+ with a custom case. Here are some links:

You’ll might need one of these to re-flash the eMMC:

An alternate method is here:

Thanks Rob!

I’ll go ahead and give the alternate method a try and see how that works. Failing that, I’ll go through the first 4 links.

1 Like

OK, so I managed to get it all hooked up and, I used the ums command on /dev/mmcblk0 all with no problem.

But then my computer won’t start up the new drive, instead reporting an error. In the device manager of windows I see the following:

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

any thoughts?

I’m at a disadvantage with HA on the N2; my experience is limited to a different application. When you use the ls command, do you see /dev/mmcblk0 listed? Can I assume the flash process doesn’t even start?

As an aside, it looks as if there have been upgrades with the Petitboot bootloader. That said, I’m not sure it’s the issue, or if an upgrade will even help. Perhaps you need a recovery image to get it to work.

I suggest two potential ways of getting help if the above links don’t help:

The preferred way is to look through the issues on GitHub and see if there’s anything with the same problem signature. If you don’t see something similar enough, write up a new issue. Hopefully, someone with relevant experience (e.g. @agners) will respond and point you in the right direction.

Here’s a similar issue:

The second path is to go to Hardkernel for help via their forum:

Either approach requires having an account.

I’m at a disadvantage with HA on the N2; my experience is limited to a different application.
You’re my hero anyway at least right now :slight_smile: This is my first experience with a pi-type computer, emmc memory, and a host of other things so I’m a bit out to sea.

When you use the ls command, do you see /dev/mmcblk0 listed?
Yes and I was successfully able to change it to ums… or at least I ran that command which gave no feedback. But running that command did cause my windows PC to “ding” and it tried to mount the drive.

Can I assume the flash process doesn’t even start?
I couldn’t even start the flash process. I got no drive letter. The windows UMS driver failed to connect properly to the drive.

I suggest two potential ways of getting help if the above links don’t help:
Thanks for all your help Rob. I’ll take this on over to the hardkernel forums.

1 Like

@JDHayes you should get a drive letter. The fact that Windows did “ding” seems that something appeared on the USB Bus. Check the Windows Drive Manager if the drive really did not appear. I’d try a different USB cable/port/Hub combination, sometimes its just USB not properly enumerating.

1 Like

OK… so with a new USB cable I’ve managed to re-flash the Odroid and got it back to the onboarding screen. I told it to use a backup that I’d made. I did NOT let it restore the full backup, but rather picked everything except the HASS core itself (the very first option). This brings me back to exactly where I started with this thread.

When I selected the file to upload, it asked me what to restore. When I hit OK, it took me right back to the onboarding screen as if nothing had happened. At this point, refreshing my web browser returns err_empty_response.

Unlike last time, this time I’m letting it go for a while. It’s been maybe 10 minutes so far and still nothing.


a) Is this the expected behavior? No progress screen or anything?
b) How long should it take to restore the backup?

This is just a guess at something that might get you up and running.

I would not do a full restore. I’d reload the OS and perform an incremental restore of add-ons and integrations. Get each one working and backed up before adding the next. If you get to a point where an something doesn’t work, restore the prior configuration and rebuild the one that breaks the installation.

Hi Rob:

That is basically what I ended up doing. I restored the integrations one at a time. The Zigbee integration I just installed from scratch and then I had to play with all my device names – tedious work but once done my naming scheme is better anyway. In the end, all the integrations restored just fine. For all I know, Zigbee would’ve also. I suspect it was some core component that was the culprit. After all, I was transferring from a VM based install to an Odroid one.

Thank you for all your help.

PS: The little HA blue box has been running like a top… way snappier than the old laptop it was running on not to mention more compact, more economical, and better at handling power loss/recovery. For anyone thinking of buying a HA Blue, I strongly recommend it as a HA hardware platform.

1 Like

I’m glad to hear it worked out. FYI, the Blue system might not be available anymore. The recommendation should be for the Hardkernel Odroid N2+ with 4GB of RAM.

I have an underused N2 (not +) I’m loaning to a friend to get him started with HA after his SmartThings hub failed. I figured it would be a ‘gateway’ host until he could find something with a proper SSD. I was surprised to find its performance was so snappy. I bought a 128GB eMMC module for it, along with a USB dongle to load HA. It’s supposed to be more robust than an SD card. Do some digging on the 'net; it might be something to consider.

HA Blue is currently still available as of this post.

For the sake of some reader down the read, if it’s not available, it’s just a bundled hardware platform in a pretty case with HA pre-installed.

Odroid N2+
128gb eMMC
4gb DDR4
Power Supply
Pretty case with HA logo on it

Anything with these hardware specs or better is going to do just fine. Mine is typically loping along at <1% CPU utilization, If you build your own, Rob gave instructions early in this thread for flashing. What I used was just a “good” USB 2.0 micro cable and these instructions. When I say a good cable, it just means not an old ratty one you’ve had laying around for who knows how many decades? I bought an inexpensive one from Amazon and it worked like a charm.

1 Like