Broadlink broken with 115

same issue here, RM mini 3, setup the integration, updated the config, but my switches are showing “entity not available”

There is a an update 0.115.1. This is suppose to fix the rm3 issue. Updating as I am writing. Hope to get it working.

I just updated to 0.115.1, still the same

I finally managed to solve the issues.
The main idea is to not use yaml configuration at all.
Read carefully the information on Release Notes. Sroll to “Breaking Changes/broadlink” section.
It looks like the broadlink integration is going to be controlled via UI, not yaml.

The only yaml configuration is used to create virtual switches to send IR commands.

yep, I didn’t notice the subtle change in the switches yaml

I had the exact codes you had before the update. After the update, a handful of IR codes did not show up in HA. I, then, redid the code as per their breaking changes. All good now.


pretty sure you have to change the config for switches

check the docs

Can I be the first that would ask how to use Broadlink anyway? 0.115 was the first time it appeared in my HA. Is there a UK YouView setup anyone can share?

I finally got all my Broadlink devices working again after updating to 0.115.1. This is what I did.
Note: I have the RM4 Pro and RM3 Mini devices. I believe this quick update was a patch fix for the RM3 Mini. The RM4 Pro works on Ver. 0.115.
If these steps do not work for you, you may have a device that isn’t supported yet. Best to check this open issue and see if they have added your device type or include yours to the list.

– Delete any previous Broadlink devices you have troubled with if the integration failed.
– Make sure you have your IR codes in a switch.yaml file in this new format.
– Update HA to 0.115.1 if you haven’t done so and restart Ha.
– After reboot, if HA does not auto discover your Broadlink devices…
– Navigate to configuration -> integrations -> click on orange + sign. Search for Broadlink
– Type the ip address of your device for HOST. Name your device and it should install a remote entity by default and any other sensors you have for Broadlink automatically.
– If you have included your IR codes in a switch.yaml before the device setup, you should see your IR codes in the frontend.
– Repeat the steps to add more devices if you have more than one.

1 Like

I’ve tried the steps above, updated the switch to the new format, but it is still not showing up in the integration, no entities. Any ideas?

Is your device either the rm4 or the rm3 mini?

After installing version 115.1 I have the similar issue. I have configured Broadlink integration, it seems OK. I have some custom switches, so I modified the configuration.yaml as mentioned above. The config check is OK, but after restarting the home assistant the switches are not shown in the user interface. An example from my configuration.yaml:

  - platform: broadlink
    mac: !secret broadlinkmac
      - name: Hálószoba

Could you please check it.

It’s Broadlink RM Pro+. It was fine running under 114. Been scratching my hairs off. Hope i don’t get bald over this :joy: My missy has been bugging me to fix it.

This guide should get you started.

It should work. My only guess is that your device type isn’t added as support yet. If you look at this post, you will see there are different device type code for RM4 Pro. You may have to wait until the next update.

I have already checked it, my device is supported: 0x2787

I’m in the same situation, running a RM Pro+. It’s not on the current list of supported devices, but it is on the list to be included in the next update. Details here:

Cool! Thanks for sharing this. :beers: I guess i can keep my hair for now. I just need to find some way to pacify my missy till the update.

I noticed that the MAC address is case sensitive now, whereas previously upper or lower case would be acceptable. As per 115 only lower case mac addresses are accepted.

1 Like

Any idea how do i find out if it is in the list of supported device? based on the documentation, RM Pro+ is supported. With the latest 115.2, it is still not working though the handling at the integration UI has been improved to show that device is unsupported.