Broadlink broken with 115

I’m not able to setup my broadlink with the new integration introduced with 115. I’ve read the breaking change, do everything that need to be done but the entity is not visible. The default imported name is in chinese I don’t know if it is a bug…

I’ve removed my previous entry in the configuration yaml, delete the old entity but it is always the same.

If someone already solved this problem ?

I also get the Chinese name, if I then type a real name I don’t see the entities (just my old stale remote entities’ and I get the following in the log

2020-09-17 21:55:32 ERROR (MainThread) [homeassistant.components.broadlink.updater] Error fetching device data: The device storage is full
2020-09-17 21:55:32 DEBUG (MainThread) [homeassistant.components.broadlink.updater] Finished fetching device data in 0.040 seconds

In case it helps this was my config

  - platform: broadlink
    name: broadlink_living
    mac: XX:XX:XX:XX:XX:XX
    type: rm_mini3_newblackbean
    timeout: 30

  - platform: broadlink
    name: broadlink_kitchen
    mac: XX:XX:XX:61:XX:XX
    type: rm_mini3_newblackbean
    timeout: 30

So same problem for you? Or is it working with your yaml configuration? Sorry it’s nnot clear :grin:

same here, I opened an issue:

Sorry if that wasn’t clear - not working - no entities created and errors in the log.

I got my Broadlink working by removing remote and sensor from config.

Switches still needs to be in config but you may need to remove everything except mac address.

1 Like

I saw this post while still under 0.115. So I updated the Zigbee2mqtt add-on. It threw and error saying a line of text is missing. I thought it was because we needed to upgrade to 0.115. Did that and still can’t start Zigbee2mqtt. Management to fix the Zigbee2mqtt add-on issue, but Broadlink is broken.

Are you folks all using the rm mini 3? Looks like that one is no longer supported.

The docs say it IS still supported

Those docs previously listed rm mini and rm mini 3 seperatly. RM Mini 3 is listed in the supported remotes anymore.

Edit: I’m an idiot…was reading it on my phone and the 3 got cut off. I did read something about it not being supported though.

Found it:

You need to read the documentation carefully… In my case all my old broadlink is working perfectly… Furthermore the renaming is also simple…just change the name from chinesse to english…
I have to upgrade my smartIR but thats it…

If you have tried to configure your rm mini 3 and your ir codes isn’t showing up after a restart of HA, use the link above neotrunks has provided and list your device type. They will add that device on their next update.

have the same issuie with same error message

Deleted old config, added 2x RM Mini 3 via integration.

All working fine.

I make sure the switches: is rewrite correctly… maybe if you have problem you can share your switch.yaml here so we can help…

@felipediel is on the case for us, with changes to the BroadLink library, and HA.

To solve, you have to change in the configuration.yaml file:

from “ controller_data: ” change to controller_data: remote.broadlink_hub_remote (I have from the name you find in -> Development Tools -> Status -> )

I can not connect sp3s plug.
My configuration:

  - platform: broadlink
    mac: 'MY_MAC_ADDRESS'
      - name: 'plug1'

I look here:
It says that sp3s supported. But it is not described how to connect them.

I got it working.


  • platform: broadlink
    mac: ‘xx:xx:xx:xx:xx:xx’
    friendly_name: “TV_AAN”
    command_on: ‘xxxxxxxxx’
    command_off: ‘xxxxxxxxx’

reboot and then integrate broadlink. Chinese name I put RMPROPLUS, reboot
In Broadlink integration on RMPROPLUS Remote click right above.

It looks like you integrated it by web UI, not by your config.